Bug 230044 - FreeBSD subversion repository contains an invalid filename for some filesystems - q-1.024.003.
Summary: FreeBSD subversion repository contains an invalid filename for some filesyste...
Status: Closed DUPLICATE of bug 232479
Alias: None
Product: Base System
Classification: Unclassified
Component: tests (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Many People
Assignee: Ed Maste
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-25 17:49 UTC by Jerker Bäck
Modified: 2019-08-12 19:36 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jerker Bäck 2018-07-25 17:49:11 UTC
Checking out FreeBSD subversion repository on Windows fails with
svn: E155000: 'q-1.024.003.' is not valid as filename in directory 'head/tools/test/sort/bigtest'

It is possible to trick subversion to pass this. In my old repository I have both the invalid q-1.024.003. and a valid q-1.024.003 counterpart. I don't remember how I did this, but I remember it was a challenge. I think the filesystem allows the file, but the OS and tools rule it out as invalid. The file itself seems to be empty, so possibly a typo?

I'm pretty sure I reported this error before as did others I think, I cannot find any trace of it in the FreeBSD bug database though. Internet search also gives several mentions of the bug.

Solution: Rename file from q-1.024.003. => q-1.024.003 (which seems logic)

cheers
Comment 1 Alan Somers freebsd_committer 2018-07-25 17:54:08 UTC
Assigning to the committer.  Is is possible to simply delete all of those 0-length files?
Comment 2 Ed Maste freebsd_committer 2019-08-12 19:36:34 UTC

*** This bug has been marked as a duplicate of bug 232479 ***