Bug 230291 - Kernel Panic when tried to create logical volume with Smartpqi storage driver on FreeBSD 12.0 Current
Summary: Kernel Panic when tried to create logical volume with Smartpqi storage driver...
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Some People
Assignee: Deepak Ukey
URL:
Keywords: panic
Depends on:
Blocks:
 
Reported: 2018-08-02 11:30 UTC by Deepak Ukey
Modified: 2018-12-30 20:09 UTC (History)
3 users (show)

See Also:


Attachments
Crash Dump (80.52 KB, text/plain)
2018-08-02 11:30 UTC, Deepak Ukey
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Deepak Ukey 2018-08-02 11:30:39 UTC
Created attachment 195760 [details]
Crash Dump

Hi,

I have smartpqi storage driver inbox with FreeBSD 12.0 Current. I am trying to create a logical volume (RAID0 or RAID1) with the drives attached to the samrtpqi controller. As i tried to create a logical volume the kernel panic is happening. 

I am not able to see the issue on FreeBSD 11.2 smartpqi inbox driver. Also i executed same test of creating logical volume with samrtpqi inbox source on FreeBSD 11.0 Release & 11.1 Release. And i am able to create logical volumes successfully. 

It looks like issue is only reproducible with FreeBSD 12.0 current. With other FreeBSD version it is working fine. 

Pleas find the attached crash dump for detail.

Regards,
Deepak
Comment 1 Conrad Meyer freebsd_committer 2018-08-02 20:03:23 UTC
This assertion is present in 11 and was added in r291074, but KASSERT()s are only compiled in with INVARIANTS enabled.

By default, CURRENT images are build with INVARIANTS enabled.

Release images like 11.1 are built with INVARIANTS *disabled*.

Probably the same panic and driver bug exists in 11, if you rebuilt the kernel with INVARIANTS.

The only significant driver difference between stable/11 (or releng/11.2) and CURRENT is r336201 ("update to release 3"), which you provided.