Bug 230313 - net/libfixbuf: Update to 2.1.0
Summary: net/libfixbuf: Update to 2.1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL: https://tools.netsa.cert.org/fixbuf/d...
Keywords:
: 230633 (view as bug list)
Depends on:
Blocks: 230314 230632
  Show dependency treegraph
 
Reported: 2018-08-03 02:57 UTC by Nathan
Modified: 2018-08-27 16:43 UTC (History)
3 users (show)

See Also:


Attachments
Update (1.46 KB, patch)
2018-08-03 02:57 UTC, Nathan
ndowens04: maintainer-approval+
Details | Diff
Portlint (261 bytes, text/plain)
2018-08-03 02:58 UTC, Nathan
no flags Details
Poudriere Log 10.4-Release (55.38 KB, text/plain)
2018-08-03 02:58 UTC, Nathan
no flags Details
Poudriere Log 11.2-Stable (48.69 KB, text/plain)
2018-08-03 02:59 UTC, Nathan
no flags Details
Poudriere Log 10.4-Release (46.58 KB, text/plain)
2018-08-03 03:00 UTC, Nathan
no flags Details
Poudriere Log 11.2-Stable (46.85 KB, text/plain)
2018-08-03 03:00 UTC, Nathan
no flags Details
Update (3.21 KB, patch)
2018-08-19 16:13 UTC, Nathan
ndowens04: maintainer-approval+
Details | Diff
Makefile Update (354 bytes, patch)
2018-08-19 16:14 UTC, Nathan
ndowens04: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan 2018-08-03 02:57:50 UTC
Created attachment 195794 [details]
Update

Changes: https://tools.netsa.cert.org/fixbuf/download.html
Comment 1 Nathan 2018-08-03 02:58:11 UTC
Created attachment 195795 [details]
Portlint
Comment 2 Nathan 2018-08-03 02:58:49 UTC
Created attachment 195796 [details]
Poudriere Log 10.4-Release
Comment 3 Nathan 2018-08-03 02:59:07 UTC
Created attachment 195797 [details]
Poudriere Log 11.2-Stable
Comment 4 Nathan 2018-08-03 03:00:06 UTC
Created attachment 195798 [details]
Poudriere Log 10.4-Release
Comment 5 Nathan 2018-08-03 03:00:42 UTC
Created attachment 195799 [details]
Poudriere Log 11.2-Stable
Comment 6 Kurt Jaeger freebsd_committer 2018-08-12 11:01:27 UTC
please do not attach the build logs (it blows up the size of the bugzilla database). Only mention that the build was sucessful.
Comment 7 Kurt Jaeger freebsd_committer 2018-08-12 11:02:19 UTC
And: which other ports depend on libfixbuf ? as the old and the new are not compatible, which ones need to be taken care of ?
Comment 8 Nathan 2018-08-12 14:23:45 UTC
(In reply to Kurt Jaeger from comment #7)
> And: which other ports depend on libfixbuf ? as the old and the new are not
> compatible, which ones need to be taken care of ?

Hmm, could be best to have a seperate port for version 2.x series
Comment 9 Nathan 2018-08-12 15:20:54 UTC
(In reply to Kurt Jaeger from comment #7)
> And: which other ports depend on libfixbuf ? as the old and the new are not
> compatible, which ones need to be taken care of ?

(In reply to Nathan from comment #8)
> (In reply to Kurt Jaeger from comment #7)
> > And: which other ports depend on libfixbuf ? as the old and the new are not
> > compatible, which ones need to be taken care of ?
> 
> Hmm, could be best to have a seperate port for version 2.x series

I have a patch ready to create libfixbuf2 port and it adds conflict with this version
Comment 10 Kubilay Kocak freebsd_committer freebsd_triage 2018-08-15 03:08:13 UTC
*** Bug 230633 has been marked as a duplicate of this bug. ***
Comment 11 Steve Wills freebsd_committer 2018-08-19 14:27:06 UTC
(In reply to Nathan from comment #9)
Please post the patch to create the new port and add conflicts.
Comment 12 Nathan 2018-08-19 16:13:55 UTC
Created attachment 196351 [details]
Update
Comment 13 Nathan 2018-08-19 16:14:15 UTC
Created attachment 196352 [details]
Makefile Update
Comment 14 Kurt Jaeger freebsd_committer 2018-08-19 16:56:02 UTC
(In reply to Kurt Jaeger from comment #7)
To answer my question:

net-mgmt/yaf
security/silktools

seem to depend on the previous version. The question is: Do they really
depend on that version or is there a newer version available that builds with the newer libfixbuf ?
Comment 15 Kurt Jaeger freebsd_committer 2018-08-19 16:58:26 UTC
yaf: there's 2.10.0 out and it builds with fixbuf2. So a sync'ed update would work without the fixbuf2 port (just updating the old one).
Comment 16 Kurt Jaeger freebsd_committer 2018-08-19 17:00:06 UTC
and: silktools 3.17.2 already builds with libfixbuf2. So: no need for a second port.
Comment 17 Chris Inacio 2018-08-20 05:00:36 UTC
net-mgmt/super_mediator also depends on libfixbuf.

There is a version of super_mediator out that will work with libfixbuf 2.x.
Comment 18 Kurt Jaeger freebsd_committer 2018-08-20 05:20:31 UTC
this is why this PR blocks two other PRs (those for super_med and yaf).
Comment 19 commit-hook freebsd_committer 2018-08-27 16:43:40 UTC
A commit references this bug:

Author: swills
Date: Mon Aug 27 16:43:06 UTC 2018
New revision: 478223
URL: https://svnweb.freebsd.org/changeset/ports/478223

Log:
  net/libfixbuf: Update to 2.1.0

  PR:		230313
  Submitted by:	Nathan <ndowens@yahoo.com>
  Approved by:	Chris Inacio <nacho319+freebsdZilla@gmail.com> (implicit)

Changes:
  head/net/libfixbuf/Makefile
  head/net/libfixbuf/distinfo
  head/net/libfixbuf/pkg-plist
Comment 20 Steve Wills freebsd_committer 2018-08-27 16:43:55 UTC
Committed, thanks!