Bug 230319 - textproc/php72-wddx: /usr/local/lib/php/20170718/xml.so - not found
Summary: textproc/php72-wddx: /usr/local/lib/php/20170718/xml.so - not found
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jochen Neumeister
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-03 05:57 UTC by Kalten
Modified: 2018-12-01 12:15 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (tz)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kalten 2018-08-03 05:57:28 UTC
Greetings!

When compiling textproc/php72-wddx inside poudriere the following error may
occure:
...8<---
> ===>   php72-wddx-7.2.8 depends on file: /usr/local/lib/php/20170718/xml.so - not found
> ===>   Installing existing package /packages/All/php72-xml-7.2.8.txz
> [112amd64-default-job-04] Installing php72-xml-7.2.8...
> [112amd64-default-job-04] Extracting php72-xml-7.2.8: ..... done
> ===>   php72-wddx-7.2.8 depends on file: /usr/local/lib/php/20170718/xml.so - not found
> *** Error code 1
--->8...

If lang/php72 has been built with debugging support (DEBUG=on),
textproc/php72-xml does not generate ‘lib/php/20170718/xml.so’ but
‘lib/php/20170718-zts-debug/xml.so’, which results in the error at least
when building textproc/php72-wddx inside poudriere.

Regards,
 Kalten
Comment 1 Kalten 2018-08-05 02:07:47 UTC
(In reply to Kalten from comment #0)
> If lang/php72 has been built with debugging support (DEBUG=on),
> textproc/php72-xml does not generate ‘lib/php/20170718/xml.so’ but
> ‘lib/php/20170718-zts-debug/xml.so’, which results in the error at least
> when building textproc/php72-wddx inside poudriere.

I am sorry, but the problem does exist in non-debug-mode too:
If lang/php72 has been built without debugging support (DEBUG=off),
textproc/php72-xml does not generate ‘lib/php/20170718/xml.so’ but
‘lib/php/20170718-zts/xml.so’, which results in the error at least
when building textproc/php72-wddx inside poudriere.

Regards,
 Kalten
Comment 2 Kalten 2018-08-08 09:55:55 UTC
(In reply to Kalten from comment #1)
The option ZTS “Force Zend Thread Safety (ZTS) build” (off by default) is
to blame.  Iff ZTS=on, we do have this problem.

Regards,
 Kalten
Comment 3 Torsten Zuehlsdorff freebsd_committer 2018-08-15 10:10:58 UTC
Aloha,

i'm sorry - currently i have no time to fix this bug. But i could reproduce it. My child will born within the next days and i will take a break because of it.

I assigned this ticket to joneum, which will take care about my PHP ports while i'm away. If you can provide a patch to fix the issue, he will happily test and commit it!

Greetings,
Torsten
Comment 4 Jochen Neumeister freebsd_committer 2018-08-15 15:55:26 UTC
I will do it :-)
Comment 5 Jochen Neumeister freebsd_committer 2018-08-15 17:54:49 UTC
(In reply to Kalten from comment #2)

Can you please give me more information?
Which FreeBSD version do you use?
Which options do you use?
Do you have a patch?
Thanks for your help :-)
Comment 6 Kalten 2018-08-20 19:41:23 UTC
Greetings Torsten!

Very Off-Topic, but I hope everybody will forgive me:

(In reply to Torsten Zuehlsdorff from comment #3)
> […] My child will born within the next days […]
All the best for the birth!!!

Good luck!
 Kalten
Comment 7 Kalten 2018-08-20 19:43:19 UTC
(In reply to Jochen Neumeister from comment #5)
Greetings!

> Can you please give me more information?
> Which FreeBSD version do you use?
11.2-RELEASE, building inside poudriere-3.2.7

> Which options do you use?
Let me summarise the information:

1) Change ZTS “Force Zend Thread Safety (ZTS) build” (off by default)
   to on in lang/php72

2) Iff you set (additionally)

2a) in lang/php72 DEBUG=on
    if you try to build e.g. textproc/php72-wddx inside ports-mgmt/poudriere
    you get the error from my original post
...8<---
> ===>   php72-wddx-7.2.8 depends on file: /usr/local/lib/php/20170718/xml.so - not found
> ===>   Installing existing package /packages/All/php72-xml-7.2.8.txz
> [112amd64-default-job-04] Installing php72-xml-7.2.8...
> [112amd64-default-job-04] Extracting php72-xml-7.2.8: ..... done
> ===>   php72-wddx-7.2.8 depends on file: /usr/local/lib/php/20170718/xml.so - not found
> *** Error code 1
--->8...
as textproc/php72-xml does not generate ‘lib/php/20170718/xml.so’ but
‘lib/php/20170718-zts-debug/xml.so’, which results in the error at least
when building textproc/php72-wddx inside poudriere.

2b) in lang/php72 DEBUG=off
    if you try to build e.g. textproc/php72-wddx inside ports-mgmt/poudriere
    you get (see my comment 1)
...8<--- same error as above:
> ===>   php72-wddx-7.2.8 depends on file: /usr/local/lib/php/20170718/xml.so - not found
> ===>   Installing existing package /packages/All/php72-xml-7.2.8.txz
> [112amd64-default-job-04] Installing php72-xml-7.2.8...
> [112amd64-default-job-04] Extracting php72-xml-7.2.8: ..... done
> ===>   php72-wddx-7.2.8 depends on file: /usr/local/lib/php/20170718/xml.so - not found
> *** Error code 1
--->8...
other reason:
As textproc/php72-xml does not generate ‘lib/php/20170718/xml.so’ but
‘lib/php/20170718-zts/xml.so’, which results in the error at least
when building textproc/php72-wddx inside poudriere.

> Do you have a patch?
No, and I am sorry but do not have sufficient spare time at the moment.

Regards,
 Kalten
Comment 8 Jochen Neumeister freebsd_committer 2018-11-11 12:36:08 UTC
(In reply to Kalten from comment #7)

Hello Kalten,

Please excuse the long waiting time. I could not reproduce the problem. I have tested it in a WM and also with poudriere. I have no problems. I have activated ZTS as you said, also DEBUG.

No problems under FreeBSD 11.2, FreeBSD 12 and FreeBSD 13-CURRENT

As an example the logs for FreeBSD 11.2:

http://joneumbox.org/build.html?mastername=112amd64-ports&build=2018-11-11_13h29m44s
http://joneumbox.org/build.html?mastername=112i386-ports&build=2018-11-11_13h29m44s


Do you still have the problems?