Bug 230379 - databases/py-sqlalchemy-migrate (and dependents): Update RUN_DEPENDS from sqlalchemy10 to sqlalchemy12
Summary: databases/py-sqlalchemy-migrate (and dependents): Update RUN_DEPENDS from sql...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
: 230395 230404 (view as bug list)
Depends on:
Blocks: 232244 232245
  Show dependency treegraph
 
Reported: 2018-08-05 09:31 UTC by Kurt Jaeger
Modified: 2019-01-12 16:20 UTC (History)
4 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
patch (868 bytes, patch)
2018-08-05 09:31 UTC, Kurt Jaeger
no flags Details | Diff
py-glance-et-al-assign-to-sqlalchemy12.patch (4.43 KB, patch)
2018-08-06 05:48 UTC, Kai
no flags Details | Diff
py-buildbot-assign-to-sqlalchemy12.patch (983 bytes, patch)
2018-08-06 05:50 UTC, Kai
no flags Details | Diff
py-openlp-assign-to-sqlalchemy12.patch (1.02 KB, patch)
2018-08-06 05:57 UTC, Kai
no flags Details | Diff
py-openlp-assign-to-sqlalchemy12-rev2.patch (1.24 KB, patch)
2018-08-06 06:03 UTC, Kai
no flags Details | Diff
keystone-et-al.patch (1.76 KB, patch)
2018-10-14 12:58 UTC, Kai
no flags Details | Diff
cleanup-sqlalchemy-deps.patch (6.04 KB, patch)
2019-01-12 14:50 UTC, Kai
no flags Details | Diff
cleanup-sqlalchemy-deps-rev1.patch (6.22 KB, patch)
2019-01-12 14:56 UTC, Kai
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2018-08-05 09:31:49 UTC
Created attachment 195898 [details]
patch

testbuilds are fine.
Comment 1 Li-Wen Hsu freebsd_committer 2018-08-06 01:15:46 UTC
Kurt: I don't have much time on this in the upcoming week, please feel free to commit what you have tested.  Thanks!  Or I will look into this next next week.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2018-08-06 05:45:30 UTC
Bug 23095 and bug 230404 changes will be merged in here, as they need to be updated together. See bug 230404 comment 6 onward.

Kai is taking care of this and will close the other issues
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2018-08-06 05:46:09 UTC
Bug 230395 and bug 230404 rather
Comment 4 Kai 2018-08-06 05:48:09 UTC
Created attachment 195934 [details]
py-glance-et-al-assign-to-sqlalchemy12.patch

This patch handles the following ports and assigns them to databases/py-sqlalchemy12:

- emulators/py-nova (no bump, because port is already set as BROKEN)
- misc/py-cinder (port bump)
- misc/py-glance (port bump and quick fix for pkg-plist)
- security/py-keystone (port bump)


QA:
~~~
- poudriere (10.4-, 11.1-, 11.2-RELEASE, 12.0-CURRENT @r337160) for each amd64 + i386 arch and each py27 + py36 flavor -> OK
- portlint -> OK
Comment 5 Kai 2018-08-06 05:50:09 UTC
Created attachment 195935 [details]
py-buildbot-assign-to-sqlalchemy12.patch

This patch assigns devel/py-buildbot to databases/py-sqlalchemy12 .

QA:
~~~
- poudriere (10.4-, 11.1-, 11.2-RELEASE, 12.0-CURRENT @r337160) for each amd64 + i386 arch and each py27 + py36 flavor -> OK
- portlint -> OK
Comment 6 Kai 2018-08-06 05:57:09 UTC
Created attachment 195936 [details]
py-openlp-assign-to-sqlalchemy12.patch

This patch assigns multimedia/py-openlp to databases/py-sqlalchemy12 .

QA:
~~~
- poudriere (12.0-CURRENT @r337160, 11.2-RELEASE) for each amd64 + i386 arch -> OK
- portlint -> OK

Note:
Builds are running at the moment for 11.1- and 10.4-RELEASE but I expect that there will be no failures.
Comment 7 Kai 2018-08-06 06:03:33 UTC
Created attachment 195937 [details]
py-openlp-assign-to-sqlalchemy12-rev2.patch

Forgot to bump PORTREVISION for multimedia/py-openlp .
Comment 8 Kai 2018-08-06 06:13:56 UTC
There are now additional patches for the following ports:

- emulators/py-nova
- misc/py-cinder
- misc/py-glance
- multimedia/py-openlp
- security/py-keystone

All those ports depends at the moment on databases/py-sqlalchemy-migrate AND py-sqlalchemy10. Thus the additional patches should be applied at the same time together with the primary patch to avoid build failures.

As far I can tell there are no more ports left with dependencies on databases/py-sqlalchemy-migrate AND databases/py-sqlalchemy10 . But maybe there's one or the other port that needs also to be patched - more eyes sees more.
Comment 9 Kai 2018-08-06 06:15:33 UTC
*** Bug 230395 has been marked as a duplicate of this bug. ***
Comment 10 Kai 2018-08-06 06:25:06 UTC
*** Bug 230404 has been marked as a duplicate of this bug. ***
Comment 11 Kai 2018-08-07 08:16:10 UTC
I can confirm now that multimedia/py-openlp builds also fine on:

10.4- and 11.1-RELEASE on amd64 + i386

But the port seems in a bad shape and that for quite a while:

> $ openlp.py
> Traceback (most recent call last):
>  File "/usr/local/bin/openlp.py", line 27, in <module>
>    from openlp.core.common import is_win, is_macosx
>  File "/usr/local/bin/openlp.py", line 27, in <module>
>    from openlp.core.common import is_win, is_macosx
> ImportError: No module named core.common

There are also missing dependencies if one tries to start the program in that way:

> $ python2.7 -m openlp
> [...]
> ImportError: No module named ipaddress

Both errors are reproducible with either databases/py-sqlalchemy10 or databases/py-sqlalchemy12 as dependency.

Thus it should be safe to mark that port as BROKEN for now.

Upstream has already 2.4.6 (see https://get.openlp.org/2.4.6/OpenLP-2.4.6.tar.gz) so that port should get an update in the next time.

TL;DR: multimedia/py-openlp builds fine on all platforms but the port itself is broken and that already for some time.
Comment 12 Kurt Jaeger freebsd_committer 2018-08-07 09:15:35 UTC
(In reply to Kai from comment #11)
The update for openlp simmers in

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=211665

with no end in sight.
Comment 13 Kai 2018-08-07 18:56:54 UTC
(In reply to Kurt Jaeger from comment #12)

Thanks for the info. I wasn't aware about that PR until yet and I think there should be an end in sight now.

I attached a patch for bug #211665 that might be committed in no time. If you see it that way I would obsolete the patch for multimedia/py-openlp and set bug #211665 as dependency for this PR.
Comment 14 Kai 2018-08-09 08:28:01 UTC
Comment on attachment 195937 [details]
py-openlp-assign-to-sqlalchemy12-rev2.patch

multimedia/py-openlp has been updated to 2.6.4 in bug #211665 and no longer depends on databases/py-sqlalchemy10 AND databases/py-sqlalchemy-migrate .
Comment 15 Kai 2018-10-14 12:58:13 UTC
Created attachment 198133 [details]
keystone-et-al.patch

misc/py-cinder and misc/py-glance are now handled in separate PRs that contain the new sqlalchemy dependencies.

So this patch addresses only security/py-keystone and emulators/py-nova.
Comment 16 Kai 2019-01-12 14:50:01 UTC
Created attachment 201061 [details]
cleanup-sqlalchemy-deps.patch

Created an all-in-one patch that includes the initial patch from pi@ and rebased versions for the other patches:

- Assigns databases/py-sqlalchemy-migrate to databases/py-sqlalchemy12
- Assigns the following ports to databases/py-sqlalchemy12:
  * devel/py-buildbot
  * misc/py-cinder
  * misc/py-glance
  * security/py-keystone
- Unbreaks devel/py-oslo.db because it is buildable when databases/py-sqlalchemy-migrate has been assigned to databases/py-sqlalchemy12
- Fixes pkg-plist for devel/py-glance after ports r489963

QA:
~~~
- poudriere (11.2-, 12.0-RELEASE, 13.0-CURRENT@r342772 amd64 + i386) -> OK
- portlint -> OK
Comment 17 Kai 2019-01-12 14:56:25 UTC
Created attachment 201062 [details]
cleanup-sqlalchemy-deps-rev1.patch

Updated version with bumped PORTREVISION also for databases/py-sqlalchemy-migrate .
Comment 18 Kurt Jaeger freebsd_committer 2019-01-12 14:59:48 UTC
thanks for reminding me...
Comment 19 Kurt Jaeger freebsd_committer 2019-01-12 15:22:23 UTC
testbuilds@work
Comment 20 Kurt Jaeger freebsd_committer 2019-01-12 15:40:13 UTC
Committed, thanks!
Comment 21 commit-hook freebsd_committer 2019-01-12 15:40:37 UTC
A commit references this bug:

Author: pi
Date: Sat Jan 12 15:40:01 UTC 2019
New revision: 490061
URL: https://svnweb.freebsd.org/changeset/ports/490061

Log:
  databases/py-sqlalchemy-migrate (and dependents):
    Update RUN_DEPENDS from sqlalchemy10 to sqlalchemy12

  - Assigns databases/py-sqlalchemy-migrate to databases/py-sqlalchemy12
  - Assigns the following ports to databases/py-sqlalchemy12:
    * devel/py-buildbot
    * misc/py-cinder
    * misc/py-glance
    * security/py-keystone
  - Unbreaks devel/py-oslo.db because it is buildable when
      databases/py-sqlalchemy-migrate
    has been assigned to
      databases/py-sqlalchemy12
  - Fixes pkg-plist for devel/py-glance after ports r489963

  PR:		230379
  Submitted by:	Kai <freebsd_ports@k-worx.org>
  Approved by:	koobs, lwhsu

Changes:
  head/databases/py-sqlalchemy-migrate/Makefile
  head/devel/py-buildbot/Makefile
  head/devel/py-oslo.db/Makefile
  head/misc/py-cinder/Makefile
  head/misc/py-glance/Makefile
  head/misc/py-glance/pkg-plist
  head/security/py-keystone/Makefile
Comment 22 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-01-12 16:20:59 UTC
Wow!
I just talked with lwhsu@ about this issue today and I saw it's fixed when I'm home.
Thank you, Kurt!