Bug 230422 - lang/ponyc: update to 0.24.4
Summary: lang/ponyc: update to 0.24.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2018-08-06 23:56 UTC by Greg V
Modified: 2018-08-12 13:22 UTC (History)
1 user (show)

See Also:


Attachments
pony.patch (5.27 KB, patch)
2018-08-06 23:56 UTC, Greg V
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2018-08-06 23:56:36 UTC
Created attachment 195957 [details]
pony.patch

+ added message about optional pcre dependency

+ not using -march=native on amd64
Comment 1 commit-hook freebsd_committer 2018-08-12 13:16:59 UTC
A commit references this bug:

Author: riggs
Date: Sun Aug 12 13:16:01 UTC 2018
New revision: 476989
URL: https://svnweb.freebsd.org/changeset/ports/476989

Log:
  Update to upstream version 0.24.4

  Details:
  - Update to 0.24.4
  - Avoid using -march=native
  - Add pkg-message to let the users know that devel/pcre2 is neded
    for regex/glob support in pony programs

  PR:		230422
  Submitted by:	greg@unrelenting.technology (mantainer)

Changes:
  head/lang/ponyc/Makefile
  head/lang/ponyc/distinfo
  head/lang/ponyc/pkg-message
  head/lang/ponyc/pkg-plist