Bug 230427 - ports-mgmt/portlint: does not run correctly
Summary: ports-mgmt/portlint: does not run correctly
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Joe Marcus Clarke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-07 06:04 UTC by takefu
Modified: 2018-08-07 12:50 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (marcus)


Attachments
portlint-2.18.3.patch (496 bytes, patch)
2018-08-07 06:04 UTC, takefu
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description takefu 2018-08-07 06:04:59 UTC
Created attachment 195965 [details]
portlint-2.18.3.patch

It looks like there was garbage in line 1717.


Bareword "n" not allowed while "strict subs" in use at /usr/ports/ports-mgmt/portlint/src/portlint.pl line 1717.
syntax error at /usr/ports/ports-mgmt/portlint/src/portlint.pl line 1717, near "/) "
Comment 1 Joe Marcus Clarke freebsd_committer 2018-08-07 12:50:01 UTC
Yep.  Looks like adamw committed to portlint on accident, but not properly backout his changes.  It's fixed now.
Comment 2 commit-hook freebsd_committer 2018-08-07 12:50:18 UTC
A commit references this bug:

Author: marcus
Date: Tue Aug  7 12:49:21 UTC 2018
New revision: 476593
URL: https://svnweb.freebsd.org/changeset/ports/476593

Log:
  Fix breakage introduced in previous commits.

  PR:		230427

Changes:
  head/ports-mgmt/portlint/src/portlint.pl