Bug 230439 - www/py-requests-toolbelt build error: invalid command 'build_sphinx'
Summary: www/py-requests-toolbelt build error: invalid command 'build_sphinx'
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Walter Schwarzenfeld
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-07 15:41 UTC by Vladimir Botka
Modified: 2019-08-14 04:48 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback? (wg)


Attachments
poudriere logfile py27-requests-toolbelt-0.8.0.log (12.40 KB, text/plain)
2018-08-07 15:41 UTC, Vladimir Botka
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Botka 2018-08-07 15:41:17 UTC
Created attachment 195978 [details]
poudriere logfile py27-requests-toolbelt-0.8.0.log

Building for py27-requests-toolbelt-0.8.0 with poudriere stopped with error: invalid command 'build_sphinx'

Poudriere logfile py27-requests-toolbelt-0.8.0.log is attached.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2018-08-07 23:08:44 UTC
Hi Vladirmir, 

requests-toolbelt doesn't attempt to run the build_sphinx target unless the DOCS option is enabled (which installs py-sphinx, which provides that command).

The attached log shows that the DOCS option is unset [1], which means py-sphinx is not added as a dependency, and as such is not installed, which is the cause of the missing build_sphinx command.

As to why/how the port is running build_sphinx when the DOCS option is disabled, that needs to be isolated. Can you provide more information on that?

[1] # Ansible managed
[1] OPTIONS_UNSET+= DOCS NLS X11 EXAMPLES
Comment 2 Walter Schwarzenfeld freebsd_triage 2019-08-13 08:46:43 UTC
Build fine in port and poudriere with DOCS=on or off. Poudriere version has changed.
Seems is overcome by events and is feedback timeout.

If there are still problems, please reopen.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2019-08-14 04:48:00 UTC
^Triage: Correct resolution, given comment 2 (unable to reproduce), which supersedes comment 1 (request feedback)