Bug 230520 - sysutils/plasma5-user-manager 5.12.5_2 repeatedly asks for password for authentication but never authenticates
Summary: sysutils/plasma5-user-manager 5.12.5_2 repeatedly asks for password for authe...
Status: In Progress
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-11 05:15 UTC by Patrick McMunn
Modified: 2018-11-10 04:02 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick McMunn 2018-08-11 05:15:28 UTC
I updated my packages today on my FreeBSD 11.2-p1 system with Plasma 5. plasma5-user-manager was a new package, and I decided to see if it works well on FreeBSD. I tried making some changes to my own and other user accounts (simple things like changing the icon). When it asked for my password, it seemed to accept my password (no error message) and then immediately ask for my password again. It will ask for my password 4 times each time I try to make any changes. If I input my password incorrectly, it will give an error message. But even after inputting my password 4 times, it apparently never gets authorization, and no changes are actually made to the accounts.
Comment 1 Tobias C. Berner freebsd_committer 2018-08-11 07:38:31 UTC
Moin moin

Given that you have _2, I assume you already have the dependency on accounts services (sysutils/accountsservice).
 
I'll look into it.


mfg Tobias
Comment 2 Patrick McMunn 2018-11-10 04:02:37 UTC
This problem exists on both Linux and FreeBSD. It is also present in 5.14.2. It appears to be an upstream KDE Plasma 5 bug rather than a FreeBSD-specific bug.