Bug 230614 - math/vtk8, science/paraview: clang 7 crashes during build
Summary: math/vtk8, science/paraview: clang 7 crashes during build
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-toolchain mailing list
URL:
Keywords: needs-qa
Depends on:
Blocks: 230355
  Show dependency treegraph
 
Reported: 2018-08-14 01:56 UTC by Jan Beich
Modified: 2018-09-16 08:10 UTC (History)
1 user (show)

See Also:


Attachments
Filters/Core/vtkUnstructuredGridQuadricDecimation.cxx (compressed, preprocessed) (410.29 KB, application/x-xz)
2018-08-14 01:58 UTC, Jan Beich
no flags Details
command line args (for clang 7) (5.06 KB, text/plain)
2018-08-14 01:58 UTC, Jan Beich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-08-14 01:56:50 UTC
$ poudriere jail -cj clang7 -a amd64 -v projects/clang700-import -m svn+https
$ poudriere testport -j clang7 math/vtk8
[...]
/usr/bin/c++  -DVTK_IN_VTK -DvtkFiltersCore_EXPORTS -IFilters/Core -I/wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Filters/Core -ICommon/Core -I/wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Common/Core -IUtilities/KWIML -I/wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Utilities/KWIML -IUtilities/KWSys -I/wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Utilities/KWSys -ICommon/DataModel -I/wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Common/DataModel -ICommon/Math -I/wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Common/Math -ICommon/Misc -I/wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Common/Misc -ICommon/System -I/wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Common/System -ICommon/Transforms -I/wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Common/Transforms -ICommon/ExecutionModel -I/wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Common/ExecutionModel -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include  -O2 -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include -fPIC -fvisibility=hidden   -std=c++11 -MD -MT Filters/Core/CMakeFiles/vtkFiltersCore.dir/vtkUnstructuredGridQuadricDecimation.cxx.o -MF Filters/Core/CMakeFiles/vtkFiltersCore.dir/vtkUnstructuredGridQuadricDecimation.cxx.o.d -o Filters/Core/CMakeFiles/vtkFiltersCore.dir/vtkUnstructuredGridQuadricDecimation.cxx.o -c /wrkdirs/usr/ports/math/vtk8/work/VTK-8.1.1/Filters/Core/vtkUnstructuredGridQuadricDecimation.cxx
PHI nodes not grouped at top of basic block!
  %e1.sroa.20.0 = phi <2 x float> [ %29, %if.then.i ], [ %11, %entry ]
label %_ZN40vtkUnstructuredGridQuadricDecimationVec49NormalizeEv.exit
PHI nodes not grouped at top of basic block!
  %e2.sroa.21.0 = phi <2 x float> [ %53, %if.then.i160 ], [ %42, %_ZN40vtkUnstructuredGridQuadricDecimationVec49NormalizeEv.exit ]
label %_ZN40vtkUnstructuredGridQuadricDecimationVec49NormalizeEv.exit161
fatal error: error in backend: Broken function found, compilation aborted!
c++: error: clang frontend command failed with exit code 70 (use -v to see invocation)
FreeBSD clang version 7.0.0 (branches/release_70 339355) (based on LLVM 7.0.0svn)
Target: x86_64-unknown-freebsd12.0
Thread model: posix
InstalledDir: /usr/bin

http://package18.nyi.freebsd.org/data/headamd64PR230355-default/2018-08-11_19h01m06s/logs/errors/vtk8-8.1.1.log
Comment 1 Jan Beich freebsd_committer 2018-08-14 01:58:28 UTC
Created attachment 196176 [details]
Filters/Core/vtkUnstructuredGridQuadricDecimation.cxx (compressed, preprocessed)
Comment 2 Jan Beich freebsd_committer 2018-08-14 01:58:59 UTC
Created attachment 196177 [details]
command line args (for clang 7)
Comment 3 Yuri Victorovich freebsd_committer 2018-08-14 02:06:06 UTC
This looks like a clang/llvm internal failure to me:

> PHI nodes not grouped at top of basic block!
>   %e1.sroa.20.0 = phi <2 x float> [ %29, %if.then.i ], [ %11, %entry ]

It should be reported to the llvm project as a regression.
Comment 4 Jan Beich freebsd_committer 2018-08-14 02:08:00 UTC
Another port bundles VTK, so Clang crashes pretty much the same way.

$ poudriere jail -cj clang7 -a amd64 -v projects/clang700-import -m svn+https
$ poudriere testport -j clang7 science/paraview
[...]
PHI nodes not grouped at top of basic block!
  %e1.sroa.20.0 = phi <2 x float> [ %29, %if.then.i ], [ %11, %entry ]
label %_ZN40vtkUnstructuredGridQuadricDecimationVec49NormalizeEv.exit
PHI nodes not grouped at top of basic block!
  %e2.sroa.21.0 = phi <2 x float> [ %53, %if.then.i160 ], [ %42, %_ZN40vtkUnstructuredGridQuadricDecimationVec49NormalizeEv.exit ]
label %_ZN40vtkUnstructuredGridQuadricDecimationVec49NormalizeEv.exit161
fatal error: error in backend: Broken function found, compilation aborted!
c++: error: clang frontend command failed with exit code 70 (use -v to see invocation)
FreeBSD clang version 7.0.0 (branches/release_70 339355) (based on LLVM 7.0.0svn)
Target: x86_64-unknown-freebsd12.0
Thread model: posix
InstalledDir: /usr/bin

http://package18.nyi.freebsd.org/data/headamd64PR230355-default/2018-08-11_19h01m06s/logs/errors/paraview-5.5.1_2.log
Comment 5 Dimitry Andric freebsd_committer 2018-09-16 08:10:03 UTC
This was fixed upstream in https://reviews.llvm.org/rL339853, for https://bugs.llvm.org/show_bug.cgi?id=38418, and merged to the release_70 branch in https://reviews.llvm.org/rL339853.

So the fix came in with base r338014, where I merged upstream release_70 r339999.