Bug 230700 - databases/mongodb32-tools: Fails to build with OpenSSL 1.1.x
Summary: databases/mongodb32-tools: Fails to build with OpenSSL 1.1.x
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL:
Keywords:
Depends on:
Blocks: 228865 231931
  Show dependency treegraph
 
Reported: 2018-08-17 13:19 UTC by Bernard Spil
Modified: 2018-12-31 13:28 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-08-17 13:19:24 UTC
"incomplete type 'BIO_METHOD'"

Likely fixed in a later release, they've switchted to a different upstream for go openssl.

During BSDCan 2018 the intention to update OpenSSL in base to 1.1.x branch was documented.

Intention is to update OpenSSL in 12-STABLE to 1.1.1 when that is released. 

Poudriere log: https://keg.brnrd.eu/data/111amd64-default-openssl110/2018-08-17_12h10m13s/logs/errors/mongodb32-tools-3.2.11.log
Comment 1 Nathan 2018-09-15 02:17:58 UTC
Built fine on 12-current with openssl-devel 1.1.0i
Comment 2 Tobias Kortkamp freebsd_committer 2018-12-13 06:45:05 UTC
(In reply to Nathan from comment #1)
Cannot confirm.  It still does not build with SSL_DEFAULT=openssl111.

Also fails on 13.0-CURRENT:
http://beefy11.nyi.freebsd.org/data/head-i386-default/p485718_s340864/logs/errors/mongodb32-tools-3.2.11.log

Port is marked deprecated anyway, so there is really nothing to do here anymore.
Comment 3 Rene Ladan freebsd_committer 2018-12-31 13:28:14 UTC
Expired port removed.