Bug 230728 - databases/mongodb36-tools: Fails to build with OpenSSL 1.1.x
Summary: databases/mongodb36-tools: Fails to build with OpenSSL 1.1.x
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: John Baldwin
URL:
Keywords:
Depends on:
Blocks: 228865
  Show dependency treegraph
 
Reported: 2018-08-18 09:56 UTC by Bernard Spil
Modified: 2019-11-17 04:31 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (numisemis)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2018-08-18 09:56:09 UTC
"incomplete type 'BIO_METHOD'"

Likely fixed in a later release, they've switchted to a different upstream for go openssl.

During BSDCan 2018 the intention to update OpenSSL in base to 1.1.x branch was documented.

Intention is to update OpenSSL in 12-STABLE to 1.1.1 when that is released. 

Poudriere log: https://keg.brnrd.eu/data/111amd64-default-openssl110/2018-08-17_12h10m13s/logs/errors/mongodb36-tools-3.6.3.log
Comment 1 Palle Girgensohn freebsd_committer 2019-01-25 10:25:48 UTC
Still breaks, any progress here?
Comment 2 John Baldwin freebsd_committer freebsd_triage 2019-11-15 18:03:25 UTC
Since this bug was opened, mongodb40-tools has been added which builds fine with newer openssl.  It probably isn't worth it try to get the older versions building with newer openssl.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2019-11-17 04:31:35 UTC
^Triage: Assign to committer that resolved