Bug 230734 - [PATCH] devel/scons 3+ supports Python3.5+
Summary: [PATCH] devel/scons 3+ supports Python3.5+
Status: Closed DUPLICATE of bug 237122
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-18 17:01 UTC by Eir Nym
Modified: 2019-08-23 03:00 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eir Nym 2018-08-18 17:01:44 UTC
SCons 3+ supports Python 3.5+ After changing Python requirements, everything goes well.

https://scons.org/tag/releases.html

Change Impact: All ports directly use this tool should be updated/fixed. but after this changes build scripts most likely will be compatible with both Python 2.7 and Python 3.5+
Comment 1 Eir Nym 2018-08-18 22:15:34 UTC
Patch for devel/jsoncpp SConstruct file is attached to the issue for this library.

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226401
Comment 2 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-04-09 13:28:05 UTC
I tested devel/scons on python 3.7 for a period of time and it works fine. I've requested an exp-run for scons 3.0.5 update, including relaxed python version. Please follow bug #237122 instead. Thanks!

*** This bug has been marked as a duplicate of bug 237122 ***