Bug 230757 - [syscons] random wrong color for kernel messages
Summary: [syscons] random wrong color for kernel messages
Status: Closed Works As Intended
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.2-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: Eitan Adler
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-08-19 19:27 UTC by koro
Modified: 2020-06-08 14:56 UTC (History)
2 users (show)

See Also:


Attachments
Screenshot (35.54 KB, image/png)
2018-08-19 19:27 UTC, koro
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description koro 2018-08-19 19:27:34 UTC
Created attachment 196359 [details]
Screenshot

Confirmed happening on two different machines, one physical and one VM.

When using VESA to set the syscons resolution via /boot/device.hints:

hint.sc.0.flags="0x180"
hint.sc.0.vesa_mode="0x14c"

Some of the kernel messages text appears in dark gray with no discernible pattern.

This started with 11.2-RELEASE.
Comment 1 Conrad Meyer freebsd_committer 2018-08-19 20:29:50 UTC
This is probably one of bde's syscons patches that added colorizing by CPU, e.g., r330918.
Comment 2 koro 2018-08-19 23:38:14 UTC
I confirm, it stops happening when I set the VM to only have one CPU, and inversely, I get more colors if I add more CPUs.

Seems like it's not a bug then.

How do I turn it off though?
Comment 3 Ed Maste freebsd_committer 2020-06-08 14:55:35 UTC
(In reply to koro from comment #2)
Have a look at the SC_KERNEL_CONS_ATTRS description in syscons(4)
Comment 4 Ed Maste freebsd_committer 2020-06-08 14:56:28 UTC
This is now syscons' default behaviour for kernel messages.