Bug 230787 - devel/llvm-cheri: fails to build with clang 7
Summary: devel/llvm-cheri: fails to build with clang 7
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Brooks Davis
URL:
Keywords: needs-qa
Depends on:
Blocks: 230355
  Show dependency treegraph
 
Reported: 2018-08-20 22:32 UTC by Jan Beich
Modified: 2018-08-21 11:53 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (brooks)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-08-20 22:32:16 UTC
$ fetch -qo /tmp/clang7.c++98.diff 'https://bugs.freebsd.org/bugzilla/attachment.cgi?id=196011'
$ poudriere jail -cj clang7 -P /tmp/clang7.c++98.diff -v projects/clang700-import -m svn+https
$ poudriere testport -j clang7 devel/llvm-cheri
[...]
In file included from tools/clang/lib/Basic/Targets.cpp:26:
In file included from tools/clang/lib/Basic/Targets/Mips.h:22:
In file included from include/llvm/IR/Cheri.h:20:
In file included from include/llvm/IR/Function.h:26:
In file included from include/llvm/IR/Argument.h:19:
include/llvm/IR/Attributes.h:74:14: fatal error: 'llvm/IR/Attributes.inc' file not found
    #include "llvm/IR/Attributes.inc"
             ^~~~~~~~~~~~~~~~~~~~~~~~

http://package18.nyi.freebsd.org/data/headamd64PR230355gnucxx98-default/2018-08-20_17h42m49s/logs/errors/llvm-cheri-7.0.d20180806.log

suggesting the following jobs aren't generated compared to Clang 6

[246/3545] cd ../.build && ../.build/bin/llvm-tblgen -gen-attrs -I include/llvm/IR -I include include/llvm/IR/Attributes.td -o include/llvm/IR/Attributes.inc.tmp -d include/llvm/IR/Attributes.inc.d
[247/3545] cd ../.build/include/llvm/IR && cmake -E copy_if_different ../.build/include/llvm/IR/Attributes.inc.tmp ../.build/include/llvm/IR/Attributes.inc

http://www.ipv6proxy.net/go.php?u=http://beefy12.nyi.freebsd.org/data/head-amd64-default/p477468_s337991/logs/llvm-cheri-7.0.d20180806.log
Comment 1 Dimitry Andric freebsd_committer 2018-08-21 10:46:45 UTC
(In reply to Jan Beich from comment #0)
> $ fetch -qo /tmp/clang7.c++98.diff
> 'https://bugs.freebsd.org/bugzilla/attachment.cgi?id=196011'
> $ poudriere jail -cj clang7 -P /tmp/clang7.c++98.diff -v
> projects/clang700-import -m svn+https
> $ poudriere testport -j clang7 devel/llvm-cheri
> [...]
> In file included from tools/clang/lib/Basic/Targets.cpp:26:
> In file included from tools/clang/lib/Basic/Targets/Mips.h:22:
> In file included from include/llvm/IR/Cheri.h:20:
> In file included from include/llvm/IR/Function.h:26:
> In file included from include/llvm/IR/Argument.h:19:
> include/llvm/IR/Attributes.h:74:14: fatal error: 'llvm/IR/Attributes.inc'
> file not found
>     #include "llvm/IR/Attributes.inc"
>              ^~~~~~~~~~~~~~~~~~~~~~~~

I think the problem lies in that "c++98" patch, since it builds just fine for me with clang 7.
Comment 2 Jan Beich freebsd_committer 2018-08-21 11:53:27 UTC
Or an intermittent as other devel/llvm* are unaffected. I can't reproduce *with* C++98 patch, see https://ptpb.pw/Zx-6