Bug 230954 - net/freerdp: build fail without devel/libepoll-shim
Summary: net/freerdp: build fail without devel/libepoll-shim
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Steve Wills
URL:
Keywords:
: 230956 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-08-27 17:11 UTC by rozhuk.im
Modified: 2018-08-27 18:19 UTC (History)
5 users (show)

See Also:


Attachments
svn(1) diff against net/freerdp (1.67 KB, patch)
2018-08-27 17:35 UTC, Kyle Evans
kevans: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2018-08-27 17:11:09 UTC
...
-- Finding recommended feature Xfixes for X11 xfixes extension (Useful additions to the X11 core protocol)
--     Disable feature Xfixes using "-DWITH_XFIXES=OFF"
-- Found Xfixes: /usr/local/lib/libXfixes.so  
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
EPOLLSHIM_LIBS
    linked by target "winpr" in directory /tmp/ports/usr/ports/net/freerdp/work/FreeRDP-2.0.0-rc3/winpr/libwinpr
synch/EPOLLSHIM_INCLUDE_DIR
   used as include directory in directory /tmp/ports/usr/ports/net/freerdp/work/FreeRDP-2.0.0-rc3/winpr/libwinpr
   used as include directory in directory /tmp/ports/usr/ports/net/freerdp/work/FreeRDP-2.0.0-rc3/winpr/libwinpr
   used as include directory in directory /tmp/ports/usr/ports/net/freerdp/work/FreeRDP-2.0.0-rc3/winpr/libwinpr
   used as include directory in directory /tmp/ports/usr/ports/net/freerdp/work/FreeRDP-2.0.0-rc3/winpr/libwinpr
   used as include directory in directory /tmp/ports/usr/ports/net/freerdp/work/FreeRDP-2.0.0-rc3/winpr/libwinpr
   used as include directory in directory /tmp/ports/usr/ports/net/freerdp/work/FreeRDP-2.0.0-rc3/winpr/libwinpr
   used as include directory in directory /tmp/ports/usr/ports/net/freerdp/work/FreeRDP-2.0.0-rc3/winpr/libwinpr
   used as include directory in directory /tmp/ports/usr/ports/net/freerdp/work/FreeRDP-2.0.0-rc3/winpr/libwinpr
   used as include directory in directory /tmp/ports/usr/ports/net/freerdp/work/FreeRDP-2.0.0-rc3/winpr/libwinpr

-- Configuring incomplete, errors occurred!
See also "/tmp/ports/usr/ports/net/freerdp/work/.build/CMakeFiles/CMakeOutput.log".
See also "/tmp/ports/usr/ports/net/freerdp/work/.build/CMakeFiles/CMakeError.log".
....


Missing dep: devel/libepoll-shim
Comment 1 rozhuk.im 2018-08-27 17:19:10 UTC
Also net/freerdp/files/patch-CMakeLists.txt can be removed.
Comment 2 Kyle Evans freebsd_committer 2018-08-27 17:35:29 UTC
Created attachment 196607 [details]
svn(1) diff against net/freerdp

Ah, sorry about that- my test build was with WAYLAND and I forgot that I added upstream dependency on libepoll-shim. =(

Attached patch should remedy, no PORTREVISION bump included since this should have no actual effect on packaging- the epoll-shim dep was mostly for part of tests that get built or something like this.
Comment 3 commit-hook freebsd_committer 2018-08-27 18:13:26 UTC
A commit references this bug:

Author: swills
Date: Mon Aug 27 18:12:36 UTC 2018
New revision: 478243
URL: https://svnweb.freebsd.org/changeset/ports/478243

Log:
  net/freerdp: Fix build failure

  PR:		230954
  Submitted by:	kevans (maintainer)
  Reported by:	rozhuk.im@gmail.com

Changes:
  head/net/freerdp/Makefile
  head/net/freerdp/files/patch-CMakeLists.txt
Comment 4 Steve Wills freebsd_committer 2018-08-27 18:13:32 UTC
Committed, thanks!
Comment 5 Carlos J. Puga Medina freebsd_committer 2018-08-27 18:19:51 UTC
*** Bug 230956 has been marked as a duplicate of this bug. ***