Bug 230958 - databases/libdrizzle-redux: Fix build with Clang 6
Summary: databases/libdrizzle-redux: Fix build with Clang 6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL: http://beefy11.nyi.freebsd.org/data/h...
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-27 19:35 UTC by Tobias Kortkamp
Modified: 2018-09-10 15:21 UTC (History)
0 users

See Also:


Attachments
databases__libdrizzle-redux.diff (6.63 KB, patch)
2018-08-27 19:35 UTC, Tobias Kortkamp
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2018-08-27 19:35:08 UTC
The build fails with Clang 6 and soon the port will be marked as
BROKEN on 12.0 and 11.2 if we do not act.

The problem is that Clang 6 has switched to C++14 by default over
C++98 (see [1]) causing all sorts of regressions.  Often this can
easily be fixed by applying a small amount of trivial patches.

We can apply them to the ports tree but if possible (and assuming
upstream development has not ceased), they should be upstreamed to
reduce future maintainance work.

[1] http://releases.llvm.org/6.0.0/tools/clang/docs/ReleaseNotes.html#c-language-changes-in-clang
Comment 1 Tobias Kortkamp freebsd_committer 2018-08-27 19:35:24 UTC
Created attachment 196610 [details]
databases__libdrizzle-redux.diff
Comment 2 commit-hook freebsd_committer 2018-09-10 15:21:29 UTC
A commit references this bug:

Author: tobik
Date: Mon Sep 10 15:20:47 UTC 2018
New revision: 479430
URL: https://svnweb.freebsd.org/changeset/ports/479430

Log:
  databases/libdrizzle-redux: Fix build with Clang 6

  libdrizzle/binlog.cc:319:48: error: invalid suffix on literal; C++11 requires a space between literal and identifier [-Wreserved-user-defined-literal]
                            "packet size error:%"PRIu32":%"PRIu32, con->packet_size, binlog_event->length);
                                                 ^

  http://beefy12.nyi.freebsd.org/data/head-amd64-default/p479076_s338486/logs/errors/libdrizzle-redux-5.1.4_2.log

  PR:		230958
  Approved by:	jim@ohlste.in (maintainer timeout, 2 weeks)

Changes:
  head/databases/libdrizzle-redux/files/
  head/databases/libdrizzle-redux/files/patch-libdrizzle_binlog.cc
  head/databases/libdrizzle-redux/files/patch-libdrizzle_field.cc
  head/databases/libdrizzle-redux/files/patch-libdrizzle_statement__param.cc