Bug 231028 - [MAINTAINER] www/mathjax upgrade to 2.7.5
Summary: [MAINTAINER] www/mathjax upgrade to 2.7.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Fernando Apesteguía
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-30 16:45 UTC by Marko Cupać
Modified: 2018-08-31 18:43 UTC (History)
3 users (show)

See Also:


Attachments
Update (881 bytes, patch)
2018-08-31 02:08 UTC, Nathan
ndowens04: maintainer-approval? (marko.cupac)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marko Cupać 2018-08-30 16:45:22 UTC
Hi,

I skipped a few releases of MathJax as I had no problems with 2.7.2. I installed 2.7.5 and I don't see any regressions, perhaps we could bump port to latest release.

Here are Makefile and distinfo patches:

--- www/mathjax/Makefile.orig   2018-01-11 14:23:48.000000000 +0100
+++ www/mathjax/Makefile        2018-08-30 18:29:22.463171000 +0200
@@ -2,7 +2,7 @@
 # $FreeBSD: head/www/mathjax/Makefile 458730 2018-01-11 13:23:48Z tobik $
 
 PORTNAME=      MathJax
-DISTVERSION=   2.7.2
+DISTVERSION=   2.7.5
 CATEGORIES=    www
 
 MAINTAINER=    marko.cupac@mimar.rs

--- www/mathjax/distinfo.orig   2018-01-11 14:23:48.000000000 +0100
+++ www/mathjax/distinfo        2018-08-30 18:30:18.430702000 +0200
@@ -1,3 +1,3 @@
-TIMESTAMP = 1515676648
-SHA256 (mathjax-MathJax-2.7.2_GH0.tar.gz) = c4c321783ff0936f0d5ff4281367401595105cc57d4ecda0bb269277496ce2e4
-SIZE (mathjax-MathJax-2.7.2_GH0.tar.gz) = 25212235
+TIMESTAMP = 1535646618
+SHA256 (mathjax-MathJax-2.7.5_GH0.tar.gz) = a25e5736553eef7b05ba00df133ad36d8f7b3b967f1e32d2f7505ac77427946f
+SIZE (mathjax-MathJax-2.7.5_GH0.tar.gz) = 25344797
Comment 1 Fernando Apesteguía freebsd_committer 2018-08-30 17:23:48 UTC
Take
Comment 2 Fernando Apesteguía freebsd_committer 2018-08-30 17:47:18 UTC
Thanks for the patch Marko,

Could you next time send the update as a patch? That helps with managing PRs since we could add the maintainer-approval flag :-)
Comment 3 Nathan 2018-08-31 02:08:09 UTC
Created attachment 196727 [details]
Update
Comment 4 commit-hook freebsd_committer 2018-08-31 18:41:41 UTC
A commit references this bug:

Author: fernape
Date: Fri Aug 31 18:41:09 UTC 2018
New revision: 478605
URL: https://svnweb.freebsd.org/changeset/ports/478605

Log:
  www/mathjax: update to 2.7.5

  ChangeLog: https://github.com/mathjax/MathJax/releases/tag/2.7.5

  PR:	231028
  Submitted by:	marko.cupac@mimar.rs (maintainer)
  Approved by:	tcberner (implicit)
  Differential Revision:	https://reviews.freebsd.org/D16956

Changes:
  head/www/mathjax/Makefile
  head/www/mathjax/distinfo
Comment 5 Fernando Apesteguía freebsd_committer 2018-08-31 18:43:02 UTC
Committed,

Thanks!