Bug 231098 - textproc/multimarkdown: Update to 6.4.0
Summary: textproc/multimarkdown: Update to 6.4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Fernando Apesteguía
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-02 15:46 UTC by Yasuhiro Kimura
Modified: 2018-10-23 07:00 UTC (History)
2 users (show)

See Also:


Attachments
patch file (2.53 KB, patch)
2018-09-02 15:46 UTC, Yasuhiro Kimura
no flags Details | Diff
[PATCH] textproc/multimarkdown: update to 6.4.0 (9.72 KB, patch)
2018-09-03 01:24 UTC, Vinícius Zavam
no flags Details | Diff
[PATCH] textproc/multimarkdown: update to 6.4.0, with ports@ (9.59 KB, patch)
2018-10-02 09:44 UTC, Vinícius Zavam
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro Kimura freebsd_committer 2018-09-02 15:46:09 UTC
Created attachment 196794 [details]
patch file

Update to 6.4.0.

Reference:
https://github.com/fletcher/MultiMarkdown-6/releases/tag/6.4.0
Comment 1 Vinícius Zavam freebsd_committer 2018-09-03 01:24:40 UTC
Created attachment 196806 [details]
[PATCH] textproc/multimarkdown: update to 6.4.0

Hi Yasuhiro,

I did try your patch here for FreeBSD 10 and 11; failed QA for PORTSDOCS and other stages (fetching) when all options are enabled [EXTRAS, CHEAT_SHEET, ..]

portlint and poudriere (testport) gave OK for this version I'm attaching now.

while here, I would like to adopt the port and help if you agree.

KR,
Comment 2 Yasuhiro Kimura freebsd_committer 2018-09-28 05:10:15 UTC
(In reply to Vinícius Zavam from comment #1)

Hello Vinicius.

Sorry for late response. I cannot reproduce your problem. So would you please check what happens with clean latest ports tree (i.e. without any patch)? If no problem happens, then my patch should work too.

As for maintainership, feel free to take it. But I think it should be handled separately. So please open new bug report to change MAINTAINER.
Comment 3 Vinícius Zavam freebsd_committer 2018-10-01 18:37:46 UTC
(In reply to Yasuhiro KIMURA from comment #2)

Hey Yasuhiro! Thank you for giving a feedback about it; appreciated.

I will have a better look though, but you can (try to) reproduce it by running a 'testport' via Poudriere like:

  # poudriere testport -j JAILNAME -p PORTSTREE textproc/multimarkdown
Comment 4 Vinícius Zavam freebsd_committer 2018-10-02 09:11:00 UTC
Sorry, I forgot to say how I changed this port's options!

  # poudriere options -n -j JAILNAME -p PORTSTREE textproc/multimarkdown
Comment 5 Vinícius Zavam freebsd_committer 2018-10-02 09:44:05 UTC
Created attachment 197707 [details]
[PATCH] textproc/multimarkdown: update to 6.4.0, with ports@

As requested by the original reporter of this issue, I am reverting MAINTAINER to ports@ and I should create a new PR to ask for this port's maintainership.

Thank you!
Comment 6 Yasuhiro Kimura freebsd_committer 2018-10-03 04:48:36 UTC
(In reply to Vinícius Zavam from comment #3)

Hi Vinícius.

I tested my patch with following conditions.

Host:       12.0-ALPHA8      amd64
Poudriere:  3.2.7
Jail:       10.4-RELEASE-p13 amd64
            11.2-RELEASE-p4  amd64
            12.0-ALPHA8      amd64
Ports Tree: ports r481098
Options:    CHEAT_SHEET=on
     	    DOCS=on
     	    EXTRAS=on
     	    HELPERS=on

And got following poudriere build logs.

10.4-RELEASE:
https://www.utahime.org/FreeBSD/poudriere/data/logs/bulk/104amd64-local-multimarkdown/2018-10-03_09h45m25s/logs/multimarkdown-6.4.0.log
11.2-RELEASE:
https://www.utahime.org/FreeBSD/poudriere/data/logs/bulk/112amd64-local-multimarkdown/2018-10-03_10h22m45s/logs/multimarkdown-6.4.0.log
12.0-ALPHA8:
https://www.utahime.org/FreeBSD/poudriere/data/logs/bulk/curamd64-local-multimarkdown/2018-10-03_11h06m54s/logs/multimarkdown-6.4.0.log

As you can see in all cases build succeeded without any problem.
So would you please provide me your poudriere build log?

Bests Regards.
Comment 7 Fernando Apesteguía freebsd_committer 2018-10-03 16:48:40 UTC
I can not reproduce the problem either.

It builds for me in {10.4,11.2}{i386,amd64} and 12i386

Runs fine in 11.2amd64 too.

Vinicius, could it be a local problem with your ports tree?
Comment 8 Vinícius Zavam freebsd_committer 2018-10-04 12:23:18 UTC
well, it looks like I really made unnecessary noise; sorry everyone!

running it again, and even getting into the create jails to play more, original patch worked. btw, inside the jail, one of the tests I ran was:

  # env DEVELOPER=yes make -C /usr/ports/textproc/multimarkdown all stage-qa

also had all options set to ON (enabled).

many thanks for all your time and concern Yasuhiro, and Fernando!

PS: I also needed to apply the patch inside the port's dir, not in the root dir of the ports tree - maybe that might have caused my prior issue with the port (:
Comment 9 Fernando Apesteguía freebsd_committer 2018-10-04 16:17:11 UTC
(In reply to Vinícius Zavam from comment #8)
No worries!
Comment 10 commit-hook freebsd_committer 2018-10-04 16:23:01 UTC
A commit references this bug:

Author: fernape
Date: Thu Oct  4 16:22:31 UTC 2018
New revision: 481233
URL: https://svnweb.freebsd.org/changeset/ports/481233

Log:
  textproc/multimarkdown: update to 6.4.0

  ChangeLog:
  https://github.com/fletcher/MultiMarkdown-6/releases/tag/6.4.0

  PR:	231098
  Submitted by:	yasu@utahime.org
  Approved by:	tcberner (mentor, implicit)

Changes:
  head/textproc/multimarkdown/Makefile
  head/textproc/multimarkdown/distinfo
  head/textproc/multimarkdown/pkg-plist
Comment 11 Fernando Apesteguía freebsd_committer 2018-10-04 16:23:56 UTC
Committed,

Thank you both!
Comment 12 commit-hook freebsd_committer 2018-10-23 07:00:36 UTC
A commit references this bug:

Author: egypcio
Date: Tue Oct 23 06:59:49 UTC 2018
New revision: 482811
URL: https://svnweb.freebsd.org/changeset/ports/482811

Log:
  per comment #2 on PR 231098, I'll take this port's maintainership (approved by PR's original reporter).

  while here, silent portlint;

      extra item placed in the USES/USE_x section, for example, "GH_ACCOUNT".

  PR:		231098
  Submitted by:	Yasuhiro KIMURA
  Reviewed by:	mat
  Approved by:	rene (mentor), Yasuhiro KIMURA
  Differential Revision:	https://reviews.freebsd.org/D17562

Changes:
  head/textproc/multimarkdown/Makefile