Bug 231126 - mail/davmail: update to 4.8.6
Summary: mail/davmail: update to 4.8.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Thomas Zander
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2018-09-03 19:42 UTC by John Hein
Modified: 2018-09-22 17:01 UTC (History)
2 users (show)

See Also:
riggs: maintainer-feedback-


Attachments
[patch] update mail/davmail to 4.8.6 (5.18 KB, patch)
2018-09-03 19:42 UTC, John Hein
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2018-09-03 19:42:07 UTC
Created attachment 196823 [details]
[patch] update mail/davmail to 4.8.6

Attached patch updates to the latest davmail release (4.8.6 from June 2018).

QA:
 - poudriere testport ok
 - portlint ok

changes since 4.8.0:

** DavMail 4.8.6 released **
Bugfix release with latest Caldav EWS enhancements, also includes fixes for old standing bugs in bug tracker.

IMAP:
- IMAP: Fix #631 IMAP SEARCH CHARSET US-ASCII fails

Caldav:
- Caldav: fix #687 can't move event to trash in a shared mailbox
- Caldav: fix multivalued field update, send DeleteItemField instead of SetItemField with an empty value when field has no value, should fix bug #682
- Caldav: Detect X-MOZ-LASTACK and X-MOZ-SNOOZE-TIME updates to avoid sending notifications on dismiss with Thunderbird

Documentation:
- Doc: update roadmap

Enhancements
- Fix #476, try to avoid deadlock with a connection manager object lock
- Fix #456 longstanding proxy handling issue
- Update spec file
- Add GPLv2 license at root


** DavMail 4.8.5 released **
More Caldav fixes, drop SWT on windows and try to improve tray support detection on various Linux distributions.

Caldav:
- Caldav: test notification dialog
- Caldav: do not throw exception on invalid email in getFreeBusyData
- Caldav: EWS isorganizer is Exchange 2013 and later only, switch to myresponsetype
- Caldav: fix #306, do not try to retrieve textbody on Exchange < 2013
- Caldav: do not try to update etag if latest response item is empty
- Caldav: fix #679, invalid date exception on recurring event with an end date update
- Caldav: fix #346, map America/Chicago to Central Standard Time instead of Central America Standard Time

Enhancements:
- Drop redline library
- Disable tray on Gnome
- Drop platform specific Linux packages, drop SWT on windows, remove dist-rpm (user build.op
ensuse.org instead), upgrade SWT to 4.6 on Linux
- Upgrade htmlcleaner to 2.21, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891916
- Fix popMarkReadOnRetr setting save
- Update winrun4j wrappers

Linux:
- Refactor icon handling, automatically adjust color/size to match common default themes on Linux and add a new davmail.trayBackgroundColor setting to let users set their own theme color
- Make spec file compatible with RHEL 7 / Centos 7

Documentation:
- Doc: cleanup supported versions


** DavMail 4.8.4 released **
The main change in this release is the new davmail.caldavAutoSchedule setting to let users choose between
client or server side calendar notification management. Most other fixes are also related to Caldav refactoring.

Caldav:
- Caldav: Add davmail.caldavAutoSchedule to GUI
- Caldav: introduce a new setting davmail.caldavAutoSchedule to enable or disable automatic scheduling in EWS mode
- Caldav: try to fix #674, do not send notifications on event update
- Caldav: EWS refactoring, avoid converting simple events to meetings
- Caldav: Restore calendar-schedule behavior in Webdav mode
- Caldav: in EWS mode, ignore urlcompname and always use itemid as item name, except if explicitly requested
- Caldav: isMeeting EWS flag is not reliable, check for attendees with displayto and displaycc
- Caldav: Fix isorganizer detection in deleteItem

IMAP:
- IMAP: fix regression on search NOT KEYWORD

Documentation:
- Documentation: fix typo in FAQ
- Doc: Improve Thunderbird LDAP documentation

Enhancements:
- EWS : cleanup from audit
- Exclude log files from build


** DavMail 4.8.3 released **
More EWS Caldav refactoring, fix regressions noticed in 4.8.2 and merge a lot of user provided patches.
New calendar event handling is not yet enabled by default, please use davmail.caldavRealUpdate=true to
check this new experimental implementation.

Caldav:
- Caldav: add cancelled translation
- Caldav: EWS refactoring, map status field, except CANCELLED not supported by Exchange
- Caldav: implement editable notifications on meeting cancel
- Caldav: do not send notifications if user canceled in edit dialog
- Caldav: Make sure we set all notification options on event update
- Caldav: Revert status conversion that triggers regressions and enable notifications on create
- Caldav: test multiline value handling in VCalendar
- Caldav: test case for loadVtimezone and searchTasksOnly
- Caldav: in loadVtimezone, delete existing temp folder first to avoid errors
- Caldav: EWS refactoring, make sure we send meeting notifications
- Caldav: fix #666 trailing "nn" added to tasks description synced from exchange
- Caldav: EWS refactoring, only update reminder info on meetings when not organizer
- Caldav: Fix meeting response body, send and save copy
- Caldav: EWS refactoring, implement edit notifications comment
- Caldav: fix task update regression

Enhancement:
- Merge #47, support soTimeout and connectionTimeout on exchange
- Merge patch #46: Maven patch to add resources in the target/davmail.jar
- Test: fix initial server and logging settings
- Copy release notes to dist on release
- Change test cases to load credentials from a separate test.properties file
- Remove old jsmooth config file
- Apply patch to fix #601 invalid davmail.server.certificate.hash format

Documentation:
- Doc: fix #320 Wrong link in documentation

IMAP:
- IMAP: Accept US-ASCII as charset in search condition
- IMAP: fix #40 KEYWORD support for spring-integrations

OSX:
- OSX: Update universalJavaApplicationStub to 2.1.0

Windows:
- Windows: Create a 64 bits installer for windows

Carddav:
- Carddav: merge patch #44 Allow disabling reading photo from contact data


** DavMail 4.8.2 released **
EWS Caldav refactoring in progress, enabled through new davmail.caldavRealUpdate setting
to avoid regressions as seen in 4.8.1.

Caldav:
- Caldav: EWS refactoring, handle mozilla alarm fields
- Caldav: EWS refactoring, implement modified occurrences
- Caldav: EWS refactoring, implement excluded dates (deleted occurrences)
- Caldav: optionally enable new EWS caldav implementation with davmail.caldavRealUpdate
- Caldav: Improve meeting response detection to avoid NullPointerException
- Caldav: EWS refactoring, implement reminder update


** DavMail 4.8.1 released **
Last release before major EWS caldav refactoring, includes only the first behaviour change:
do not delete existing meeting on Accept/Decline, just send answer to organizer. Also includ
es
central directory photo handling in Carddav service, improved Java 9 support and many other
bug fixes.

Caldav:
- Caldav: temporarily disable EWS refactoring
- Caldav: EWS refactoring, implement multiple day recurrence and end date
- Caldav: EWS refactoring, first recurrence implementation step, improve ignore etag handling
- Caldav: EWS refactoring, manage attendees
- Caldav: prepare calendar refactoring, do not delete/add received meeting items, just send an Accept/Decline message
- Caldav: fix regression, busy status is case sensitive in EWS
- Caldav: fix #657 Tentative events shows as accepted in Thunderbird with user provided patch
- Caldav: experimental davmail.ignoreNoneMatchStar to let DavMail overwrite existing event automatically processed by Exchange.

Carddav:
- Carddav: implement get photo from Active Directory

Enhancements:
- update winrun4j wrappers
- Upgrade slf4j to 1.7.25 (patch #45)
- Fix 654: trim OWA/EWS url
- Ant: improve java version check
- Remove useless debug statement

Smartcard:
- Smartcard: improve Java 9 error handling, no longer need a temporary file
- Smartcard: try to implement code compatible with all java versions including Java 9

IMAP:
- IMAP: implement ON search filter
- IMAP: detect icedove header fetch to improve performance
- IMAP: make sure we never return null even with broken 0 uid message

POP:
- POP3: Improve documentation on trash/sent folders purge, change default value from 90 to 0 (disable)

Linux:
- Linux: check system tray with gtk_status_icon_get_geometry only with Unity to avoid regression with other window managers

SWT:
- SWT: wait 10s for tray icon to be created

OSX:
- OSX: fix Info.plist path
- OSX: fix JavaApplicationStub, do not expand folder classpath
- OSX: revert change to JavaX new key, does not work
- OSX: Update Info.plist to match new universalJavaApplicationStub
Comment 1 Thomas Zander freebsd_committer 2018-09-22 14:01:17 UTC
Maintainer timeout
Comment 2 commit-hook freebsd_committer 2018-09-22 14:05:34 UTC
A commit references this bug:

Author: riggs
Date: Sat Sep 22 14:04:36 UTC 2018
New revision: 480385
URL: https://svnweb.freebsd.org/changeset/ports/480385

Log:
  Update to upstream version 4.8.6

  Details:
  - Detailed list of changes since previous ports tree version 4.8.0
    documented by John Hein (submitter) in bug report at
    https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=231126

  PR:		231126
  Submitted by:	z7dr6ut7gs@snkmail.com
  Approved by:	Maintainer timeout

Changes:
  head/mail/davmail/Makefile
  head/mail/davmail/distinfo
  head/mail/davmail/pkg-plist