Bug 231188 - many functions are missing dtrace probe points
Summary: many functions are missing dtrace probe points
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: arm (show other bugs)
Version: CURRENT
Hardware: arm64 Any
: --- Affects Many People
Assignee: Andrew Turner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-05 23:21 UTC by John-Mark Gurney
Modified: 2021-03-02 14:14 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John-Mark Gurney freebsd_committer 2018-09-05 23:21:31 UTC
on an arm64 box, many functions are not listed in dtrace -l.  For example, on my A64-LTS board, the awg_probe and many other functions are not listed:
# dtrace -l | grep awg_
 3543        fbt            kernel                   awg_init_locked entry
 3544        fbt            kernel                   awg_init_locked return
 3545        fbt            kernel                  awg_media_status entry
 3546        fbt            kernel                awg_miibus_statchg entry

I'd expect awg_probe and many others to be present.
Comment 1 Allan Jude freebsd_committer 2021-03-01 23:50:41 UTC
Are you still seeing this?

I'm seeing awg_attach() and awg_probe() etc on my ARM64 machine running 14-CURRENT
Comment 2 Mark Johnston freebsd_committer 2021-03-02 14:14:01 UTC
I believe this was fixed by commit c00ec4dab276414ccc8a0712dd2f836bb17349d7:

Dump of assembler code for function awg_attach:                                                                                               
   0xffff00000084e424 <+0>:     sub     sp, sp, #0xf0                                                                                         
   0xffff00000084e428 <+4>:     stp     x29, x30, [sp, #144]                                                                                  
   0xffff00000084e42c <+8>:     stp     x28, x27, [sp, #160]                                                                                  
   0xffff00000084e430 <+12>:    stp     x26, x25, [sp, #176]                                                                                  
   0xffff00000084e434 <+16>:    stp     x24, x23, [sp, #192]                                                                                  
   0xffff00000084e438 <+20>:    stp     x22, x21, [sp, #208]                                                                                  
   0xffff00000084e43c <+24>:    stp     x20, x19, [sp, #224]                                                                                  
   0xffff00000084e440 <+28>:    add     x29, sp, #0x90

# dtrace -l | grep awg_
15981        fbt            kernel                        awg_attach entry
15982        fbt            kernel                        awg_attach return
15983        fbt            kernel                     awg_dmamap_cb entry
15984        fbt            kernel                     awg_dmamap_cb return
15985        fbt            kernel                    awg_hash_maddr entry
15986        fbt            kernel                    awg_hash_maddr return
15987        fbt            kernel                          awg_init entry
15988        fbt            kernel                          awg_init return
15989        fbt            kernel                   awg_init_locked entry
15990        fbt            kernel                   awg_init_locked return
15991        fbt            kernel                          awg_intr entry
15992        fbt            kernel                          awg_intr return
15993        fbt            kernel                         awg_ioctl entry
15994        fbt            kernel                         awg_ioctl return
15995        fbt            kernel                  awg_media_change entry
15996        fbt            kernel                  awg_media_change return
15997        fbt            kernel                  awg_media_status entry
15998        fbt            kernel                  awg_media_status return
15999        fbt            kernel                awg_miibus_readreg entry
16000        fbt            kernel                awg_miibus_readreg return
16001        fbt            kernel                awg_miibus_statchg entry
16002        fbt            kernel                awg_miibus_statchg return
16003        fbt            kernel               awg_miibus_writereg entry
16004        fbt            kernel               awg_miibus_writereg return
16005        fbt            kernel                     awg_newbuf_rx entry
16006        fbt            kernel                     awg_newbuf_rx return
16007        fbt            kernel                         awg_probe entry
16008        fbt            kernel                         awg_probe return
16009        fbt            kernel                awg_setup_rxfilter entry
16010        fbt            kernel                awg_setup_rxfilter return
16011        fbt            kernel                         awg_start entry
16012        fbt            kernel                         awg_start return
16013        fbt            kernel                  awg_start_locked entry
16014        fbt            kernel                  awg_start_locked return
16015        fbt            kernel                          awg_tick entry
16016        fbt            kernel                          awg_tick return
16017        fbt            kernel                         awg_txeof entry
16018        fbt            kernel                         awg_txeof return

I'm not sure if the problem is completely fixed, but in the absence of other
examples, let's close the bug.  It can be reopened if need be.