Bug 231226 - devel/clinfo: failing with installed ICD (devel/ocl-icd)
Summary: devel/clinfo: failing with installed ICD (devel/ocl-icd)
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on: 233495
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-07 14:34 UTC by O. Hartmann
Modified: 2019-08-18 05:05 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-09-07 14:34:01 UTC
In case an ICD, devel/ocl-icd, is installed, port devel/clinfo fails with 

: CommandLine Error: Option 'enable-value-profiling' registered more than once!
LLVM ERROR: inconsistency in registered CommandLine options
Comment 1 O. Hartmann 2018-09-07 14:35:44 UTC
See also Bug 219562 .
Comment 2 Niclas Zeising freebsd_committer 2018-09-08 07:34:49 UTC
I'm not sure what to do with this, as it seems like a bug in llvm rather than ocl-icd or clinfo.
Comment 3 Walter Schwarzenfeld freebsd_triage 2019-08-11 13:07:54 UTC
I cannot reproduce this error, is this still relevant?