Bug 231235 - [handbook] [patch] update x11-wm for kde5
Summary: [handbook] [patch] update x11-wm for kde5
Status: Closed FIXED
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Guangyuan Yang
URL:
Keywords: patch
: 233272 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-07 17:20 UTC by Loïc Bartoletti
Modified: 2019-01-13 11:31 UTC (History)
3 users (show)

See Also:


Attachments
x11-wm : exit kde4 hello kde5 (2.76 KB, patch)
2018-09-07 17:20 UTC, Loïc Bartoletti
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Loïc Bartoletti 2018-09-07 17:20:18 UTC
Created attachment 196951 [details]
x11-wm : exit kde4 hello kde5

Since kde5 is landing, I propose to update the documentation on the installation of kde by moving to kde5/plasma and adding a note on SDDM instead of kdm
Comment 1 Guangyuan Yang freebsd_committer 2018-11-27 04:42:56 UTC
*** Bug 233272 has been marked as a duplicate of this bug. ***
Comment 2 Guangyuan Yang freebsd_committer 2018-12-12 06:31:48 UTC
(In reply to lbartoletti from comment #0)

Thanks for the patch! Could you please submit it to reviews.freebsd.org so it's easier to review?
Comment 3 Loïc Bartoletti 2019-01-10 21:52:11 UTC
Hi,

Done here https://reviews.freebsd.org/D18813
Comment 4 commit-hook freebsd_committer 2019-01-13 11:30:13 UTC
A commit references this bug:

Author: bcr
Date: Sun Jan 13 11:29:32 UTC 2019
New revision: 52765
URL: https://svnweb.freebsd.org/changeset/doc/52765

Log:
  Remove instructions about outdated KDE4 and replace
  them with KDE5 Plasma.

  The instructions are rewritten to cover KDE5 specifics
  like installing the necessary packages (SDDM).

  Happy KDE5-ing on FreeBSD!

  PR:			231235
  Submitted by:		lbartoletti@tuxfamily.org
  Reviewed by:		kde@, tcberner@
  Approved by:		tcberner@
  Differential Revision:	https://reviews.freebsd.org/D18813

Changes:
  head/en_US.ISO8859-1/books/handbook/x11/chapter.xml
Comment 5 Benedict Reuschling freebsd_committer 2019-01-13 11:31:22 UTC
The patch from the review was committed. Thank you for those updates to the handbook! PR closed.