Bug 231248 - emulators/wine-devel: expose Vulkan support
Summary: emulators/wine-devel: expose Vulkan support
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Gerald Pfeifer
URL:
Keywords: patch
Depends on: 222175
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-08 22:21 UTC by Jan Beich
Modified: 2018-10-16 00:07 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gerald)


Attachments
v0 (5.19 KB, patch)
2018-09-08 22:21 UTC, Jan Beich
jbeich: maintainer-approval? (gerald)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-09-08 22:21:17 UTC
Created attachment 196973 [details]
v0

VKD3D + VULKAN built fine on:
- 10.4 i386 as wine-devel, see https://ptpb.pw/32M5
- 12.0 i386 as i386-wine-devel, see https://ptpb.pw/RUqb
Comment 1 Gerald Pfeifer freebsd_committer 2018-10-06 20:45:59 UTC
Thanks for doing this, Jan!  (And, sorry, apparently I had failed to hit
"Save Changes" when providing feedback originally.)

As far as the changes to wine-devel are concerned, I primarily have one
question: Why two options, VKD3D and VULKAN?

Does each of those make sense by itself, without the respective other?
Wouldn't it be easier for users to have just one?  (And for us to maintain?)


Regarding the new vkd3d port: Thanks, though I don't feel very much of an
expert there.  Would you be interested to maintain this yourself?

In the pkg-description of that new port, mind using https://www.winehq.org
instead of http://www.winehq.org/ , i.e., no trailing slash but https?
Comment 2 Jan Beich freebsd_committer 2018-10-12 19:33:40 UTC
Will you enable Vulkan option(s) by default? This may attract more interested folks to help with

- amdgpu/radv needs proper auth, see https://github.com/FreeBSDDesktop/kms-drm/issues/33
- i915/anv needs root, see https://github.com/FreeBSDDesktop/DEPRECATED-freebsd-base-graphics/issues/132
                           https://bz-attachments.freebsd.org/attachment.cgi?id=187401
- nvidia-driver needs shim, see https://forums.freebsd.org/threads/unreal-engine-4-20.66785/#post-397179

(In reply to Gerald Pfeifer from comment #1)
> As far as the changes to wine-devel are concerned, I primarily have one
> question: Why two options, VKD3D and VULKAN?

Because VKD3D already existed since ports r473250. Ask yourself. ;)

> Does each of those make sense by itself, without the respective other?

Yep. VULKAN is for Vulkan-native support (e.g., Doom 2016). VKD3D is for Direct3D 12 over Vulkan.

> Wouldn't it be easier for users to have just one?  (And for us to maintain?)

I don't care.

> Regarding the new vkd3d port: Thanks, though I don't feel very much of an
> expert there.  Would you be interested to maintain this yourself?

It's a simple port and part of Wine project but OK. I can run vkd3d demos locally in order to check for regressions on updates. Having low bus factor isn't good, though.
Comment 3 Jan Beich freebsd_committer 2018-10-12 19:36:12 UTC
(In reply to Jan Beich from comment #2)
> ... i.e., no trailing slash but https?

Terminating slash is required by PHB, see
https://www.freebsd.org/doc/en/books/porters-handbook/porting-desc.html#porting-pkg-descr
Comment 4 commit-hook freebsd_committer 2018-10-16 00:01:30 UTC
A commit references this bug:

Author: jbeich
Date: Tue Oct 16 00:00:48 UTC 2018
New revision: 482194
URL: https://svnweb.freebsd.org/changeset/ports/482194

Log:
  emulators/wine-devel: expose Vulkan support

  VULKAN is for Vulkan-native while VKD3D is for Direct3D 12 games

  PR:		231248

Changes:
  head/emulators/wine-devel/Makefile
  head/graphics/Makefile
  head/graphics/vkd3d/
  head/graphics/vkd3d/Makefile
  head/graphics/vkd3d/distinfo
  head/graphics/vkd3d/files/
  head/graphics/vkd3d/files/patch-libs_vkd3d_vkd3d__private.h
  head/graphics/vkd3d/pkg-descr
  head/graphics/vkd3d/pkg-plist