Bug 231262 - [patch] math/coinmp: use INSTALL_TARGET=install-strip, fix 'present but cannot be compiled' warnings
Summary: [patch] math/coinmp: use INSTALL_TARGET=install-strip, fix 'present but canno...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Carlos J. Puga Medina
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-09 11:46 UTC by Andriy Voskoboinyk
Modified: 2018-09-11 23:10 UTC (History)
0 users

See Also:
cpm: maintainer-feedback+


Attachments
Makefile.diff (1.27 KB, patch)
2018-09-09 11:46 UTC, Andriy Voskoboinyk
no flags Details | Diff
Portlint -AC output (186 bytes, text/plain)
2018-09-09 11:47 UTC, Andriy Voskoboinyk
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andriy Voskoboinyk freebsd_committer 2018-09-09 11:46:12 UTC
Created attachment 196985 [details]
Makefile.diff

The warning is caused by another exit(3) definition in configure (without _Noreturn attribute); it may be fixed by running ln -s ${WRKSRC}/BuildTools <into all directories with configure.ac> && 'autoreconf -fi -I${WRKSRC}/BuildTools', but 'sed' approach seems to be faster and less complicated.

While here, replace manual stripping with INSTALL_TARGET=install-strip.
Comment 1 Andriy Voskoboinyk freebsd_committer 2018-09-09 11:47:29 UTC
Created attachment 196986 [details]
Portlint -AC output
Comment 2 commit-hook freebsd_committer 2018-09-11 23:08:16 UTC
A commit references this bug:

Author: cpm
Date: Tue Sep 11 23:07:59 UTC 2018
New revision: 479573
URL: https://svnweb.freebsd.org/changeset/ports/479573

Log:
  - Use INSTALL_TARGET=install-strip instead of manual stripping
  - Fix 'present but cannot be compiled' warnings

  PR:		231262
  Submitted by:	avos

Changes:
  head/math/coinmp/Makefile
Comment 3 Carlos J. Puga Medina freebsd_committer 2018-09-11 23:10:27 UTC
Committed, thanks!