Bug 231286 - devel/llvm40: is obsolete and should be removed
Summary: devel/llvm40: is obsolete and should be removed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on: 224584 230116 231287 231288 231289 231290 235872 236477 236514
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-10 16:35 UTC by Brooks Davis
Modified: 2019-06-30 10:45 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brooks Davis freebsd_committer 2018-09-10 16:35:23 UTC
devel/llvm40 is increasingly old and unsupported.  Dependencies need to be analyzed and where possible removed to allow for eventual removal.

Current analysis can be found on:
https://wiki.freebsd.org/ObsoleteLLVMVersions
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2018-09-11 22:07:06 UTC
Cite 230116 instead of 231244.
Comment 2 commit-hook freebsd_committer 2019-03-20 21:40:16 UTC
A commit references this bug:

Author: brooks
Date: Wed Mar 20 21:40:03 UTC 2019
New revision: 496388
URL: https://svnweb.freebsd.org/changeset/ports/496388

Log:
  Switch to LLVM_DEFAULT from an hardcoded llvm40.

  This removes the LLVM40 option.

  PR:		236477, 231286
  Approved by:	ashish (maintainer)

Changes:
  head/lang/rubinius/Makefile
Comment 3 Rene Ladan freebsd_committer 2019-06-30 10:45:26 UTC
Expired port removed.