Bug 231315 - Recommend using Etcher instead of Win32 Disk Imager for writing img to USB
Summary: Recommend using Etcher instead of Win32 Disk Imager for writing img to USB
Status: Closed Works As Intended
Alias: None
Product: Documentation
Classification: Unclassified
Component: Documentation (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-doc (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-12 02:30 UTC by Rebecca Cran
Modified: 2020-09-10 04:09 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rebecca Cran freebsd_committer 2018-09-12 02:30:04 UTC
Etcher - https://etcher.io/ - is an application that runs on Windows, macOS and Linux to "Flash OS images to SD cards & USB drives, safely and easily."

It might be easier for users to use Etcher instead of Win32 Disk Imager that's currently recommended on https://www.freebsd.org/doc/handbook/bsdinstall-pre.html in the section titled "Procedure 2.2. Using Windows® to Write the Image".
Comment 1 Alexey Dokuchaev freebsd_committer 2020-09-10 03:09:59 UTC
(In reply to Rebecca Cran from comment #0)
Are you seriously suggesting that instead of clean and simple ~100KB program Windows users should download some Electron/NodeJS-based ~150MB (balenaEtcher-Setup-1.5.45.exe) monstrosity just to flash the image?

I honestly don't see how's that any improvement.
Comment 2 Rebecca Cran freebsd_committer 2020-09-10 04:00:35 UTC
I've changed my mind on this!
There are security concerns around how much data is sent back to Balena, and as Alexey says it's overly complicated for what it does.
Comment 3 Rebecca Cran freebsd_committer 2020-09-10 04:00:57 UTC
Close this, since I no longer recommend people use Etcher.
Comment 4 Alexey Dokuchaev freebsd_committer 2020-09-10 04:09:28 UTC
(In reply to Rebecca Cran from comment #2)
> I've changed my mind on this!
Thank you. :-)