Bug 231329 - graphics/mesa-dri: fails to build with GCC after 17.0.* update
Summary: graphics/mesa-dri: fails to build with GCC after 17.0.* update
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-09-12 14:44 UTC by Jan Beich
Modified: 2018-10-28 05:07 UTC (History)
1 user (show)

See Also:


Attachments
v0 (692 bytes, patch)
2018-09-12 14:44 UTC, Jan Beich
jbeich: maintainer-approval? (x11)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2018-09-12 14:44:53 UTC
Created attachment 197055 [details]
v0

$ pkg install gcc7
$ CC=gcc7 CXX=g++7 make BATCH= -C /usr/ports/graphics/mesa-dri
[...]
configure: error: --enable-llvm is required when building r300
Comment 1 commit-hook freebsd_committer 2018-10-28 05:05:23 UTC
A commit references this bug:

Author: jbeich
Date: Sun Oct 28 05:04:41 UTC 2018
New revision: 483225
URL: https://svnweb.freebsd.org/changeset/ports/483225

Log:
  graphics/mesa-dri: unbreak GCC build after r438198

  configure: error: --enable-llvm is required when building r300

  PR:		231329
  Approved by:	maintainer timeout (1 month)

Changes:
  head/graphics/mesa-dri/Makefile
Comment 2 Jan Beich freebsd_committer 2018-10-28 05:07:06 UTC
Oops, timeout is off by 2 weeks. It was 1.5 months. ;)