Bug 231436 - lang/go: Fails to build on 11.2-RELEASE-arm-armv6-RPI2
Summary: lang/go: Fails to build on 11.2-RELEASE-arm-armv6-RPI2
Status: Closed DUPLICATE of bug 221297
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Some People
Assignee: Julien Laffaye
Depends on:
Reported: 2018-09-17 23:42 UTC by Hyun Hwang
Modified: 2018-09-19 20:46 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (jlaffaye)

Build log (failed) (9.55 KB, text/plain)
2018-09-17 23:42 UTC, Hyun Hwang
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hyun Hwang 2018-09-17 23:42:56 UTC
Created attachment 197179 [details]
Build log (failed)

The entire screen dump is attached.
It appears that the build error belongs to Go 1.11; the build dependency lang/go14 is built just fine.

I think this issue is different from bug #221297.
Comment 1 Nathan 2018-09-18 17:20:26 UTC
Seems they are the same, the issue is around 1.11 in bug#221297 So this report is a duplicate
Comment 2 Nathan 2018-09-18 17:21:16 UTC
(In reply to Nathan from comment #1)
Gonna double check, but I think they are related
Comment 3 Nathan 2018-09-18 17:32:40 UTC
I was getting the same error as you, but even after that patch it still doesn't build. It does come close
Comment 4 Hyun Hwang 2018-09-19 20:46:52 UTC
(In reply to Nathan from comment #1)

Yes, you are right; my bad on not reading that PR thoroughly. This is duplicate, per the comment of linimon@.

*** This bug has been marked as a duplicate of bug 221297 ***