Bug 231488 - dns/unbound: Fails to configure (missing pkgconfig dependency)
Summary: dns/unbound: Fails to configure (missing pkgconfig dependency)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Steve Wills
URL:
Keywords: easy, regression
: 231527 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-19 21:13 UTC by Matthias Fechner
Modified: 2018-10-01 23:36 UTC (History)
4 users (show)

See Also:
jaap: maintainer-feedback+


Attachments
Patch to fix problem (789 bytes, patch)
2018-09-23 13:00 UTC, Jaap Akkerhuis
jaap: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Fechner freebsd_committer 2018-09-19 21:13:27 UTC
With the upgrade to version 1.8.0 it fails to compile:
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... -D_THREAD_SAFE
checking for PTHREAD_PRIO_INHERIT... yes
checking for pthread_spinlock_t... yes
checking for pthread_rwlock_t... yes
checking if -pthread unused during linking... no
./configure: 16926: Syntax error: word unexpected (expecting ")")
===>  Script "configure" failed unexpectedly.
Please report the problem to jaap@NLnetLabs.nl [maintainer] and attach the
"/wrkdirs/usr/ports/dns/unbound/work/unbound-1.8.0/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/dns/unbound
=>> Cleaning up wrkdir
===>  Cleaning for unbound-1.8.0
build of dns/unbound | unbound-1.8.0 ended at Wed Sep 19 23:11:10 CEST 2018
build time: 00:00:12
!!! build failure encountered !!!

For full log, please see here:
https://pkg.fechner.net/data/111amd64-default/2018-09-19_23h10m42s/logs/errors/unbound-1.8.0.log
Comment 1 Nathan 2018-09-19 21:26:19 UTC
(In reply to Matthias Fechner from comment #0)
Ok, I've tried 11.2 and 12-current and I didn't get this error
Comment 2 Steve Wills freebsd_committer 2018-09-20 05:44:19 UTC
Does adding pkgconfig to the USES line fix it for you? If so, I'll go ahead and commit that, I think that's the issue.
Comment 3 Matthias Fechner freebsd_committer 2018-09-20 07:46:40 UTC
(In reply to Steve Wills from comment #2)
Thanks that fixes it:
-USES=           autoreconf cpe libtool ssl
+USES=           autoreconf cpe libtool ssl pkgconfig
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2018-09-20 09:43:02 UTC
Change in comment 3 is

Approved by: portmgr (blanket, fix dependencies)
Comment 5 Jaap Akkerhuis 2018-09-20 12:01:00 UTC
I still cannot reproduce the problem. But if using pkconfig fixes it, I'm fine
Comment 6 commit-hook freebsd_committer 2018-09-20 14:42:37 UTC
A commit references this bug:

Author: swills
Date: Thu Sep 20 14:42:34 UTC 2018
New revision: 480177
URL: https://svnweb.freebsd.org/changeset/ports/480177

Log:
  dns/unbound: Fix configure in some cases

  Fix configure by adding missing pkgconfig to uses

  PR:		231488
  Submitted by:	leres (solution, via email), mfechner (patch)
  Reported by:	leres, mfechner
  Approved by:	jaap@NLnetLabs.nl (maintainer)

Changes:
  head/dns/unbound/Makefile
Comment 7 Steve Wills freebsd_committer 2018-09-20 14:45:58 UTC
Fix committed, thanks all!
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2018-09-21 01:27:29 UTC
*** Bug 231527 has been marked as a duplicate of this bug. ***
Comment 9 Steve Wills freebsd_committer 2018-09-21 02:00:58 UTC
(In reply to jaap from comment #5)

Did you try building with the LIBEVENT option off? That is what triggers it. Perhaps we should remove the LIBEVENT_USES=pkgconfig line now...
Comment 10 Jaap Akkerhuis 2018-09-21 10:44:35 UTC
(In reply to Steve Wills from comment #9)
Yes, "LIBEVENT option off" seems the trigger, thanks for finding this.

And removing "LIBEVENT_USES=pkgconfig" fixes this cae. Before we call victory
I'll do some more test with/without various option combinations.
Comment 11 Jaap Akkerhuis 2018-09-23 13:00:47 UTC
Created attachment 197397 [details]
Patch to fix problem

Patches Makefile of port
Comment 12 Matthias Fechner freebsd_committer 2018-09-23 18:34:12 UTC
I'm not sure if your patch really fixes the problem, as I do not have LIBEVENT set:
# This file is auto-generated by 'make config'.
# Options for unbound-1.7.2
_OPTIONS_READ=unbound-1.7.2
_FILE_COMPLETE_OPTIONS_LIST=DNSCRYPT DNSTAP DOCS ECDSA EVAPI FILTER_AAAA GOST HIREDIS LIBEVENT MUNIN_PLUGIN PYTHON SUBNET TFOCL TFOSE THREADS
OPTIONS_FILE_UNSET+=DNSCRYPT
OPTIONS_FILE_UNSET+=DNSTAP
OPTIONS_FILE_SET+=DOCS
OPTIONS_FILE_SET+=ECDSA
OPTIONS_FILE_UNSET+=EVAPI
OPTIONS_FILE_UNSET+=FILTER_AAAA
OPTIONS_FILE_SET+=GOST
OPTIONS_FILE_UNSET+=HIREDIS
OPTIONS_FILE_UNSET+=LIBEVENT
OPTIONS_FILE_UNSET+=MUNIN_PLUGIN
OPTIONS_FILE_UNSET+=PYTHON
OPTIONS_FILE_UNSET+=SUBNET
OPTIONS_FILE_UNSET+=TFOCL
OPTIONS_FILE_UNSET+=TFOSE
OPTIONS_FILE_SET+=THREADS
Comment 13 Matthias Fechner freebsd_committer 2018-09-23 18:45:30 UTC
(In reply to jaap from comment #11)
sry, misread your patch, it works for me, please ignore my comment #c12
Comment 14 commit-hook freebsd_committer 2018-10-01 23:34:41 UTC
A commit references this bug:

Author: swills
Date: Mon Oct  1 23:33:41 UTC 2018
New revision: 481078
URL: https://svnweb.freebsd.org/changeset/ports/481078

Log:
  dns/unbound: remove unnecessary LIBEVENT_USES

  PR:		231488
  Submitted by:	jaap@NLnetLabs.nl (maintainer)

Changes:
  head/dns/unbound/Makefile
Comment 15 Steve Wills freebsd_committer 2018-10-01 23:36:35 UTC
Committed, thanks!