Bug 231561 - In psmioctl(), for MOUSE_GETMODE, accelfactor is never returned.
Summary: In psmioctl(), for MOUSE_GETMODE, accelfactor is never returned.
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 11.2-RELEASE
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-21 18:41 UTC by corvid
Modified: 2020-10-23 03:51 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description corvid 2018-09-21 18:41:58 UTC
I had a look at CURRENT via svnweb, and it looks like the bug still exists.
Comment 1 Vladimir Kondratyev freebsd_committer 2018-09-24 14:13:23 UTC
(In reply to corvid from comment #0)
I do not see any problems here. Line 2620 should copy all sc->mode content including accelfactor member in to internal ioctl buffer.
https://github.com/freebsd/freebsd/blob/releng/11.2/sys/dev/atkbdc/psm.c#L2620

Could you provide a test case?