Bug 231596 - devel/lasi: fix build with GCC-based architectures
Summary: devel/lasi: fix build with GCC-based architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Lars Engels
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-22 18:02 UTC by Piotr Kubaj
Modified: 2018-09-25 07:54 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (lme)


Attachments
patch (366 bytes, patch)
2018-09-22 18:02 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2018-09-22 18:02:06 UTC
Created attachment 197360 [details]
patch

USES=compiler:c++11-lang is required on platforms that still use base GCC.

Also, while here, add USES=gnome, because:
/!\ lasi-1.1.1_5: Makefile warnings, please consider fixing /!\

Using USE_GNOME alone is deprecated, please add USES=gnome.
Comment 1 commit-hook freebsd_committer 2018-09-25 07:54:26 UTC
A commit references this bug:

Author: linimon
Date: Tue Sep 25 07:53:26 UTC 2018
New revision: 480646
URL: https://svnweb.freebsd.org/changeset/ports/480646

Log:
  Fix build on gcc-based archs.

  PR:		231596
  Submitted by:	Piotr Kubaj
  Approved by:	portmgr (tier-2 blanket)

Changes:
  head/devel/lasi/Makefile