Bug 231609 - sysutils/py-salt: Update to 2018.3.2 (Fixes Python 3 runtime)
Summary: sysutils/py-salt: Update to 2018.3.2 (Fixes Python 3 runtime)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Wen Heping
URL:
Keywords:
: 231340 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-22 20:49 UTC by Christer Edwards
Modified: 2018-10-11 07:46 UTC (History)
6 users (show)

See Also:


Attachments
patch (1.71 KB, patch)
2018-09-22 20:49 UTC, Christer Edwards
no flags Details | Diff
poudriere testport (610.74 KB, text/plain)
2018-09-22 20:50 UTC, Christer Edwards
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christer Edwards 2018-09-22 20:49:47 UTC
Created attachment 197374 [details]
patch

This patch updates Salt to 2018.3.2 and also (finally) patches the PY3 loader issue.
Comment 1 Christer Edwards 2018-09-22 20:50:17 UTC
Created attachment 197375 [details]
poudriere testport
Comment 2 Nathan 2018-09-23 02:56:14 UTC
Comment on attachment 197374 [details]
patch

+PORTREVISION=	1
Remove, not needed since version was bumped up
Comment 3 commit-hook freebsd_committer 2018-09-24 13:46:45 UTC
A commit references this bug:

Author: wen
Date: Mon Sep 24 13:45:56 UTC 2018
New revision: 480606
URL: https://svnweb.freebsd.org/changeset/ports/480606

Log:
  - Update to 2018.3.2
  - Fix the py3 loader issue

  PR:		231609
  Submitted by:	christer.edwards@gmail.com(maintainer)

Changes:
  head/sysutils/py-salt/Makefile
  head/sysutils/py-salt/distinfo
  head/sysutils/py-salt/files/patch-salt_loader.py
Comment 4 Kevin Bowling freebsd_committer 2018-10-11 07:46:37 UTC
*** Bug 231340 has been marked as a duplicate of this bug. ***