Bug 231746 - lua loader does not work on PowerPC
Summary: lua loader does not work on PowerPC
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: powerpc Any
: --- Affects Many People
Assignee: Andreas Tobler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-26 17:36 UTC by Andreas Tobler
Modified: 2018-10-09 15:47 UTC (History)
3 users (show)

See Also:


Attachments
Netboot 2018-09-24 (19.17 KB, image/jpeg)
2018-09-26 17:36 UTC, Andreas Tobler
no flags Details
Diskboot 2018-08-24 (20.38 KB, image/jpeg)
2018-09-26 17:37 UTC, Andreas Tobler
no flags Details
Diskboot 2018-09-24 (17.58 KB, image/jpeg)
2018-09-26 17:37 UTC, Andreas Tobler
no flags Details
Netboot 2018-09-24 (434.19 KB, image/jpeg)
2018-09-26 17:43 UTC, Andreas Tobler
no flags Details
Diskboot 2018-08-24 (532.28 KB, image/jpeg)
2018-09-26 17:43 UTC, Andreas Tobler
no flags Details
Diskboot 2018-09-24 (385.33 KB, image/jpeg)
2018-09-26 17:44 UTC, Andreas Tobler
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Tobler freebsd_committer 2018-09-26 17:36:04 UTC
Created attachment 197525 [details]
Netboot 2018-09-24

The Lua Loader does not work on powerpc/powerpc64. Both powerpc architectures share the same loader binary.

The first attached picture shows an error when net booting the powerpc (PowerMac in this case)

The second picture shows an error when booting from disk back on the 24.8

The third picture shows an error when booting from disk on the 23.9.

I hope the naming of the attachment is self speaking.
Comment 1 Andreas Tobler freebsd_committer 2018-09-26 17:37:01 UTC
Created attachment 197526 [details]
Diskboot 2018-08-24
Comment 2 Andreas Tobler freebsd_committer 2018-09-26 17:37:33 UTC
Created attachment 197527 [details]
Diskboot 2018-09-24
Comment 3 Andreas Tobler freebsd_committer 2018-09-26 17:43:27 UTC
Created attachment 197528 [details]
Netboot 2018-09-24
Comment 4 Andreas Tobler freebsd_committer 2018-09-26 17:43:57 UTC
Created attachment 197529 [details]
Diskboot 2018-08-24
Comment 5 Andreas Tobler freebsd_committer 2018-09-26 17:44:21 UTC
Created attachment 197530 [details]
Diskboot 2018-09-24
Comment 6 Andreas Tobler freebsd_committer 2018-09-26 17:45:06 UTC
The first batch of pictures was too small.
Comment 7 Conrad Meyer freebsd_committer 2018-09-28 20:12:25 UTC
Any idea what that error status decodes to?  Probably unaligned access but if we can get a faulting address and turn it into a code location that might help.