Bug 231765 - graphics/wayland: fix build with mips, mips64, powerpc64
Summary: graphics/wayland: fix build with mips, mips64, powerpc64
Status: Closed DUPLICATE of bug 227423
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-27 17:59 UTC by Piotr Kubaj
Modified: 2018-10-20 23:12 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
patch (2.65 KB, patch)
2018-09-27 17:59 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2018-09-27 17:59:26 UTC
Created attachment 197552 [details]
patch

prctl() function currently doesn't exist in FreeBSD. When compiling with clang on amd64, only a warning is emitted when this function is used:
tests/test-runner.c:349:8: warning: implicit declaration of function 'prctl' is invalid in C99 [-Wimplicit-function-declaration]
                rc = prctl(PR_SET_PTRACER, pid);
                     ^
tests/test-runner.c:349:8: warning: this function declaration is not a prototype [-Wstrict-prototypes]

But when compiling with base GCC (as is on e.g. powerpc64), I'm getting error:
./.libs/libtest-runner.a(test-runner.o): In function `is_debugger_attached':
/tmp/usr/local/poudriere/ports/default/graphics/wayland/work/wayland-1.14.0/tests/test-runner.c:349: undefined reference to `prctl'

Since it doesn't work even on amd64 properly (even though it compiles), let's remove this reference.

Tested on amd64 and powerpc64.

Hardware sponsored by IntegriCloud.
Comment 1 Jan Beich freebsd_committer 2018-10-20 23:12:37 UTC
Fixed as part of the update.

*** This bug has been marked as a duplicate of bug 227423 ***