Bug 231821 - multimedia/clipgrab: Update to 3.7.2, Take MAINTAINER'ship
Summary: multimedia/clipgrab: Update to 3.7.2, Take MAINTAINER'ship
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL: https://reviews.freebsd.org/D17908
Keywords:
: 232177 (view as bug list)
Depends on:
Blocks: 232177
  Show dependency treegraph
 
Reported: 2018-09-30 13:14 UTC by kikadf
Modified: 2018-12-10 04:40 UTC (History)
1 user (show)

See Also:


Attachments
patch (2.72 KB, patch)
2018-09-30 13:14 UTC, kikadf
no flags Details | Diff
patch v2 (2.72 KB, patch)
2018-10-10 12:19 UTC, kikadf
no flags Details | Diff
patch v3 (Qt5 support) (3.17 KB, patch)
2018-10-11 14:49 UTC, kikadf
no flags Details | Diff
patch v4 (Qt5 support with FLAVORS) (2.65 KB, patch)
2018-11-07 10:18 UTC, kikadf
no flags Details | Diff
patch v5 (2.41 KB, patch)
2018-11-12 15:15 UTC, kikadf
no flags Details | Diff
patch v6 (2.41 KB, patch)
2018-11-20 17:20 UTC, kikadf
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description kikadf 2018-09-30 13:14:46 UTC
Created attachment 197630 [details]
patch

Update to the latest release, fix mastersite, take maintanership.

Tested with portlint, ok. 
Use on amd64 FreeBSD 11.2-RELEASE-p4, works fine.
Comment 1 kikadf 2018-10-10 12:19:07 UTC
Created attachment 197999 [details]
patch v2

Updated to latest 3.7.1 release.
Comment 2 kikadf 2018-10-11 14:49:40 UTC
Created attachment 198037 [details]
patch v3 (Qt5 support)

Add Qt5 support and slave port.
Comment 3 Tobias Kortkamp freebsd_committer 2018-11-05 21:50:02 UTC
(In reply to kikadf from comment #2)
I don't not see a slave port in either of the patches.  Anyway I think this 
should be using flavors and not an old-school slave port.

-PLIST_FILES=	bin/${PORTNAME} \
-		%%DATADIR%%/icon.png \
-		%%DATADIR%%/logo.png \
-		%%DATADIR%%/paypal-logo.png \
-		%%DATADIR%%/splash.png

This should have been preserved (with maybe %%DATADIR%% -> ${DATADIR}).
There is no need for a pkg-plist if the port only installs 5 files.
Comment 4 kikadf 2018-11-07 10:18:49 UTC
Created attachment 199044 [details]
patch v4 (Qt5 support with FLAVORS)

The patch of Qt5 slave port is in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232177, I add that in the blocks section.

However I rewrote the patch with FLAVORS. I like FLAVORS stuff ;)
Removed the pkg-plist file.

Now I should close the clipgrab-qt5 PR, the closed-duplicate of this is the correct close options?
Comment 5 Tobias Kortkamp freebsd_committer 2018-11-07 21:55:59 UTC
(In reply to kikadf from comment #4)
> Now I should close the clipgrab-qt5 PR, the closed-duplicate of this is the 
> correct close options?

Use your best judgement.

> However I rewrote the patch with FLAVORS. I like FLAVORS stuff ;)
> Removed the pkg-plist file.

FLAVORS require portmgr approval so it would be good if you put it up on
Phabricator (https://reviews.freebsd.org) for review.
Comment 6 kikadf 2018-11-08 15:10:27 UTC
*** Bug 232177 has been marked as a duplicate of this bug. ***
Comment 7 kikadf 2018-11-12 15:15:40 UTC
Created attachment 199167 [details]
patch v5

Add changes based on review D17908.
(Use only Qt5 based clipgrab)
Comment 8 kikadf 2018-11-20 17:20:09 UTC
Created attachment 199388 [details]
patch v6

Bump version to latest 3.7.2.

Still OK the things.
Comment 9 commit-hook freebsd_committer 2018-12-09 20:03:17 UTC
A commit references this bug:

Author: tobik
Date: Sun Dec  9 20:03:02 UTC 2018
New revision: 487078
URL: https://svnweb.freebsd.org/changeset/ports/487078

Log:
  multimedia/clipgrab: Update to 3.7.2

  - Add Qt 5 support
  - Assign new maintainer

  PR:		231821
  Submitted by:	kikadf.01@gmail.com (maintainer)
  Differential Revision:	https://reviews.freebsd.org/D17908

Changes:
  head/multimedia/clipgrab/Makefile
  head/multimedia/clipgrab/distinfo
  head/multimedia/clipgrab/pkg-descr