Bug 231875 - x11/gdm does not start with nvidia driver as of 11/30/2018
Summary: x11/gdm does not start with nvidia driver as of 11/30/2018
Status: Closed DUPLICATE of bug 226403
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-02 12:34 UTC by mvharding
Modified: 2019-01-18 17:54 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
/var/log/gdm greeter log file. (2.35 KB, text/plain)
2018-10-02 12:34 UTC, mvharding
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mvharding 2018-10-02 12:34:36 UTC
Created attachment 197708 [details]
/var/log/gdm greeter log file.

I'm running 11.2 x64 with a Nvidia 1050 Ti graphics card, and have my own Poudriere cluster.  For the most part, this has worked very well, I have been running this basic setup for years without an issue save one issue with a particular issue of the Nvidia driver.  As of 9/30, with the nvidia driver installed, gdm no longer launches gnome3 as apparently the ghome shell does not launch because of Clutter failing to intialize.  I've enclosed a copy of the gdm greeter log file.

I am not sure exactly what change triggered the issue, x11/nvidia-driver and a bunch of other, I think Gnome3, ports changed around the same time.

I've switched to 'mate' using 'slim' to launch it as a workaround for now, and this seems to work fine.
Comment 1 mvharding 2018-10-03 02:48:59 UTC
I should note that gnome3/gdm does work fine on a VM with the same poudriere repo (without nvidia, obviously) and other versions of nvidia-driver exhibit the same issue.  So it's likely some interaction between components.
Comment 2 mvharding 2018-10-05 16:08:01 UTC
I tried reinstalling all the ports from the quarterly update, and had the same results, and also, asked if there was anybody who had this working on the 'gnome' forum and there was one response where they had the same issue.
Comment 3 mvharding 2018-10-06 17:12:10 UTC
After applying the patch in 226403, Gnome starts working properly.
Comment 4 mvharding 2018-10-06 17:22:52 UTC
Sorry should say bug 226403 to generate a link...
Comment 5 Tijl Coosemans freebsd_committer 2019-01-18 17:54:56 UTC

*** This bug has been marked as a duplicate of bug 226403 ***