Bug 231876 - sysutils/nomad doesn't build on 11_2-amd64
Summary: sysutils/nomad doesn't build on 11_2-amd64
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: John Hixson
URL:
Keywords:
Depends on: 232203
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-02 13:06 UTC by rainer
Modified: 2019-01-24 19:41 UTC (History)
2 users (show)

See Also:
jhixson: maintainer-feedback+


Attachments
nomad poudriere build log (845.42 KB, text/plain)
2018-10-02 13:06 UTC, rainer
no flags Details
nomad 0.8.6 build on freebsd 11.2 (854.19 KB, text/plain)
2019-01-05 08:57 UTC, John Hixson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description rainer 2018-10-02 13:06:10 UTC
Created attachment 197709 [details]
nomad poudriere build log

Hi,


2018Q4 ports'tree.

I get the following error:

packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/google.golang.org/grpc/grpclog=$WORK/b456/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/google.golang.org/grpc/internal=$WORK/b457/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/google.golang.org/grpc/metadata=$WORK/b458/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/google.golang.org/grpc/naming=$WORK/b459/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/google.golang.org/grpc/stats=$WORK/b460/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/google.golang.org/grpc/tap=$WORK/b461/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/google.golang.org/grpc/transport=$WORK/b462/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/golang.org/x/net/http2/hpack=$WORK/b445/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/golang.org/x/net/idna=$WORK/b446/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/golang.org/x/net/lex/httplex=$WORK/b451/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/golang.org/x/net/internal/timeseries=$WORK/b453/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/google.golang.org/grpc/peer=$WORK/b463/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/golang.org/x/text/secure/bidirule=$WORK/b447/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/golang.org/x/text/unicode/norm=$WORK/b450/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/golang.org/x/text/transform=$WORK/b448/_pkg_.a
packagefile github.com/hashicorp/nomad/vendor/github.com/hashicorp/go-discover/provider/gce/vendor/golang.org/x/text/unicode/bidi=$WORK/b449/_pkg_.a
EOF
mkdir -p $WORK/b001/exe/
cd .
/usr/local/go/pkg/tool/freebsd_amd64/link -o $WORK/b001/exe/a.out -importcfg $WORK/b001/importcfg.link -buildmode=exe -buildid=K4GCkAxuqADH_nmL_YMP/3jhyzmUTu8WBideqdAo_/xK_qJFGK6CDmEwbbqzQ-/K4GCkAxuqADH_nmL_YMP -X main.GitDescribe=v0.8.4 -extld=clang $WORK/b001/_pkg_.a
# github.com/hashicorp/nomad
github.com/hashicorp/nomad/vendor/golang.org/x/crypto/blake2b.supportsAVX2: relocation target runtime.support_avx2 not defined
github.com/hashicorp/nomad/vendor/golang.org/x/crypto/blake2b.supportsAVX: relocation target runtime.support_avx not defined
*** Error code 2

Stop.
make: stopped in /usr/ports/sysutils/nomad
=>> Cleaning up wrkdir
===>  Cleaning for nomad-0.8.4
build of sysutils/nomad | nomad-0.8.4 ended at Tue Oct  2 10:14:24 CEST 2018
build time: 00:00:42
!!! build failure encountered !!!
Comment 1 Luca Pizzamiglio freebsd_committer 2018-11-28 15:58:54 UTC
With commit r486097 (resolving PR 232203), nomad is up to date to 0.8.6.

Can you please check if this PR is still relevant for you?
Comment 2 John Hixson freebsd_committer 2019-01-05 08:57:44 UTC
Created attachment 200789 [details]
nomad 0.8.6 build on freebsd 11.2

I've tested the port on 11.2 and cannot duplicate this issue.
Comment 3 Thanos 2019-01-16 08:05:53 UTC
MARKED AS SPAM
Comment 4 John Hixson freebsd_committer 2019-01-24 19:41:13 UTC
Since I can't reproduce this, I am closing this ticket.