Bug 231940 - multimedia/librtmp : fails to build with openssl 1.1.1
Summary: multimedia/librtmp : fails to build with openssl 1.1.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ben Woods
URL: https://github.com/xbmc/inputstream.r...
Keywords:
: 232649 (view as bug list)
Depends on:
Blocks: 231931
  Show dependency treegraph
 
Reported: 2018-10-04 13:26 UTC by Antoine Brodin
Modified: 2018-11-02 05:47 UTC (History)
6 users (show)

See Also:
woodsb02: maintainer-feedback-
woodsb02: merge-quarterly+


Attachments
Fix openssl 1.1.x build (12.83 KB, patch)
2018-10-07 21:48 UTC, Nathan
no flags Details | Diff
Fix Openssl 1.1.x (152 bytes, patch)
2018-10-08 02:13 UTC, Nathan
no flags Details | Diff
Fix openssl (7.01 KB, patch)
2018-10-08 02:20 UTC, Nathan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Nathan 2018-10-07 19:47:04 UTC
Working on this one, should have a patch ready soon
Comment 2 Nathan 2018-10-07 21:48:18 UTC
Created attachment 197892 [details]
Fix openssl 1.1.x build

multimedia/librtmp:
 
 * Fix OpenSSL 1.1.x build
 * Removed Makefile patches, fails to apply and no longer needed
 * Add LICENSE file, while here
 
 PR:             231940
 Submitted by:   Nathan <ndowens@yahoo.com>
Comment 3 Antoine Brodin freebsd_committer 2018-10-07 22:05:07 UTC
(In reply to Nathan from comment #2)
The DHInit part doesn't look valid to me.
Comment 4 Nathan 2018-10-08 02:13:25 UTC
Created attachment 197898 [details]
Fix Openssl 1.1.x
Comment 5 Nathan 2018-10-08 02:20:11 UTC
Created attachment 197899 [details]
Fix openssl
Comment 6 Andrey Fesenko 2018-10-20 07:35:57 UTC
Bump

Commit need
Comment 7 Ben Woods freebsd_committer 2018-10-22 11:49:18 UTC
Hi Nathan,
Am I correct in saying this latest patch you submitted is taken from the GitHub repo here?
https://github.com/JudgeZarbi/RTMPDump-OpenSSL-1.1

This compiles ok for me.

Cheers,
Ben
Comment 8 Nathan 2018-10-22 11:51:51 UTC
(In reply to Ben Woods from comment #7)
If I remember correctly, it was
Comment 9 commit-hook freebsd_committer 2018-10-23 11:59:27 UTC
A commit references this bug:

Author: woodsb02
Date: Tue Oct 23 11:59:17 UTC 2018
New revision: 482833
URL: https://svnweb.freebsd.org/changeset/ports/482833

Log:
  multimedia/librtmp: Fix build with OpenSSL 1.1.x

  - Update LICENSE and add LICENSE_FILE

  PR:		231940
  Submitted by:	Nathan <ndowens@yahoo.com>
  Reported by:	antoine
  Approved by:	hrs (maintainer timeout)
  Obtained from:	https://github.com/JudgeZarbi/RTMPDum-OpenSSL-1.1
  MFH:		2018Q4

Changes:
  head/multimedia/librtmp/Makefile
  head/multimedia/librtmp/files/patch-dh.h
  head/multimedia/librtmp/files/patch-handshake.h
  head/multimedia/librtmp/files/patch-hashswf.c
Comment 10 Ben Woods freebsd_committer 2018-10-23 12:00:39 UTC
Committed - thanks for your submission!
Awaiting approval to merge to ports quarterly branch.
Comment 12 Martin Birgmeier 2018-10-23 19:31:56 UTC
See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232568
Comment 13 Nathan 2018-10-23 19:33:55 UTC
(In reply to Martin Birgmeier from comment #12)
Probably just needs some if statements for older , in which I can do later if no one submits before I do
Comment 14 commit-hook freebsd_committer 2018-10-23 19:37:27 UTC
A commit references this bug:

Author: antoine
Date: Tue Oct 23 19:36:42 UTC 2018
New revision: 482870
URL: https://svnweb.freebsd.org/changeset/ports/482870

Log:
  Revert r482833, it broke librtmp consumers

  PR:		231940
  With hat:	portmgr

Changes:
  head/multimedia/librtmp/Makefile
  head/multimedia/librtmp/files/patch-dh.h
  head/multimedia/librtmp/files/patch-handshake.h
  head/multimedia/librtmp/files/patch-hashswf.c
Comment 15 Tobias Kortkamp freebsd_committer 2018-10-24 18:13:47 UTC
*** Bug 232649 has been marked as a duplicate of this bug. ***
Comment 16 commit-hook freebsd_committer 2018-10-25 11:55:24 UTC
A commit references this bug:

Author: woodsb02
Date: Thu Oct 25 11:54:50 UTC 2018
New revision: 482967
URL: https://svnweb.freebsd.org/changeset/ports/482967

Log:
  multimedia/librtmp: Fix build with OpenSSL 1.1.x

  - Update LICENSE and add LICENSE_FILE

  PR:		231940
  Reported by:	antoine
  Approved by:	hrs (maintainer timeout)
  Obtained from:	https://github.com/xbmc/inputstream.rtmp/blob/master/depends/common/librtmp/0003-openssl-1.1.patch
  MFH:		2018Q4

Changes:
  head/multimedia/librtmp/Makefile
  head/multimedia/librtmp/files/patch-openssl-1.1
Comment 17 O. Hartmann 2018-10-27 05:59:39 UTC
The application of this patch seems to solve the reported issue at least for me on recent 12-STABLE and 13-CURRENT.
Comment 18 commit-hook freebsd_committer 2018-11-01 18:13:58 UTC
A commit references this bug:

Author: antoine
Date: Thu Nov  1 18:13:05 UTC 2018
New revision: 483697
URL: https://svnweb.freebsd.org/changeset/ports/483697

Log:
  MFH: r482967

  multimedia/librtmp: Fix build with OpenSSL 1.1.x

  - Update LICENSE and add LICENSE_FILE

  PR:		231940
  Reported by:	antoine
  Approved by:	hrs (maintainer timeout)
  Obtained from:	https://github.com/xbmc/inputstream.rtmp/blob/master/depends/common/librtmp/0003-openssl-1.1.patch

Changes:
_U  branches/2018Q4/
  branches/2018Q4/multimedia/librtmp/Makefile
  branches/2018Q4/multimedia/librtmp/files/patch-openssl-1.1
Comment 19 Ben Woods freebsd_committer 2018-11-01 23:10:28 UTC
Merged to 2018Q4.