Bug 231943 - databases/xtrabackup: fails to install on 11.2
Summary: databases/xtrabackup: fails to install on 11.2
Status: Closed DUPLICATE of bug 230836
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-04 14:05 UTC by bagas
Modified: 2018-10-06 21:20 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (aleks)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bagas 2018-10-04 14:05:56 UTC
Installation error xtrabackup-2.4.12.


FreeBSD 11.2-RELEASE-p4 amd64



/etc/make.conf
CPUTYPE?=nocona
#NO_PROFILE=true
#CFLAGS= -O -pipe
#MAKE_JOBS_NUMBER=6
#NO_CLEAN=YES
#NO_PROFILE=true
#NO_CPU_CFLAGS=false
#NO_CPU_COPTFLAGS=false
KERNCONF=base_eli_03102018
NO_GAMES=true
NO_INET6=true
NO_BLUETOOTH=true
NO_SHAREDOCS=true
WITHOUT_IPV6=yes
OPTIONS_UNSET=DOCS X11 IPV6
#DEFAULT_VERSIONS+=perl5=5.24
MAKE_JOBS_UNSAFE=yes



[ 26%] Building CXX object storage/innobase/CMakeFiles/innobase_embedded.dir/row/row0sel.cc.o
cd /usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/storage/innobase && /usr/bin/c++  -DCOMPILER_HINTS -DHAVE_CONFIG_H -DHAVE_IB_ATOMIC_PTHREAD_T_GCC=1 -DHAVE_IB_GCC_ATOMIC_COMPARE_EXCHANGE=1 -DHAVE_IB_GCC_ATOMIC_THREAD_FENCE=1 -DHAVE_IB_GCC_SYNC_SYNCHRONISE=1 -DHAVE_LIBEVENT1 -DHAVE_LZ4=1 -DHAVE_NANOSLEEP=1 -DMUTEX_EVENT -DXTRABACKUP -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/include -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/extra/rapidjson/include -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/libbinlogevents/include -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/libbinlogevents/export -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/extra/lz4 -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/storage/innobase/include -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/storage/innobase/handler -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/sql -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/sql/auth -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/regex -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/extra/yassl/include -I/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/extra/yassl/taocrypt/include -O2 -pipe -march=nocona -fstack-protector -fno-strict-aliasing -Wall -Wextra -Wformat-security -Wvla -Woverloaded-virtual -Wno-unused-parameter -Wno-null-conversion -Wno-unused-private-field -O2 -pipe -march=nocona -fstack-protector -fno-strict-aliasing -DDBUG_OFF   -fPIC -o CMakeFiles/innobase_embedded.dir/row/row0sel.cc.o -c /usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/storage/innobase/row/row0sel.cc
/usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12/storage/innobase/row/row0sel.cc:5178:29: error: comparison between pointer and integer ('void *' and 'int')
                    && prebuilt->idx_cond == false && end_loop >= 100) {
                       ~~~~~~~~~~~~~~~~~~ ^  ~~~~~
1 error generated.
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/databases/xtrabackup/work/percona-xtrabackup-2.4.12
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/xtrabackup
root@BASE_ELI:/usr/ports/databases/xtrabackup #
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-10-06 21:20:08 UTC

*** This bug has been marked as a duplicate of bug 230836 ***