Bug 231970 - irc/irssi : fails to build with openssl 1.1.1
Summary: irc/irssi : fails to build with openssl 1.1.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks: 231931
  Show dependency treegraph
 
Reported: 2018-10-05 05:31 UTC by Antoine Brodin
Modified: 2018-10-20 08:18 UTC (History)
3 users (show)

See Also:
dor.bsd: maintainer-feedback+


Attachments
Fix openssl (3.09 KB, patch)
2018-10-05 16:43 UTC, Nathan
no flags Details | Diff
Proposed patch (2.06 KB, patch)
2018-10-06 16:03 UTC, Antoine Brodin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Nathan 2018-10-05 11:16:58 UTC
I’ll work on this one
Comment 2 Nathan 2018-10-05 11:52:01 UTC
(In reply to Nathan from comment #1)
Have it working now but I got to fix it to where it works on older OpenSSL as well
Comment 3 David O'Rourke 2018-10-05 12:02:23 UTC
Upstream had worked on this in the past for OpenSSL 1.1.0, https://github.com/irssi/irssi/pull/628/files

Was the fix incomplete or did OpenSSL 1.1.1 change things further and break this?

Thanks for working on this.
Comment 4 Nathan 2018-10-05 16:43:48 UTC
Created attachment 197816 [details]
Fix openssl

 irc/irssi:                                                                                            * Fix OpenSSL build                                * Correct order of variables, while here
Comment 5 Nathan 2018-10-05 16:44:49 UTC
Fixed it to where it builds on OpenSSL base and OpenSSL devel+
Comment 6 David O'Rourke 2018-10-05 16:46:20 UTC
Looks good, thanks!
Comment 7 David O'Rourke 2018-10-05 16:46:49 UTC
Comment on attachment 197816 [details]
Fix openssl

Approving patch.
Comment 8 Antoine Brodin freebsd_committer 2018-10-06 15:29:14 UTC
The patch doesn't look good to me.
Comment 9 Antoine Brodin freebsd_committer 2018-10-06 16:03:35 UTC
Created attachment 197839 [details]
Proposed patch

Proposed patch (untested)
Comment 10 Nathan 2018-10-06 16:08:00 UTC
Comment on attachment 197839 [details]
Proposed patch

That should work. Used the changed (configure.ac) on a port that I am also working on and it worked
Comment 11 Nathan 2018-10-06 16:09:39 UTC
(In reply to Nathan from comment #10)
Tested patch and it does work Antoine
Comment 12 commit-hook freebsd_committer 2018-10-14 16:25:00 UTC
A commit references this bug:

Author: antoine
Date: Sun Oct 14 16:24:08 UTC 2018
New revision: 482051
URL: https://svnweb.freebsd.org/changeset/ports/482051

Log:
  Fix configure with openssl 1.1.1

  PR:		231970

Changes:
  head/irc/irssi/Makefile
  head/irc/irssi/files/patch-configure.ac
Comment 13 commit-hook freebsd_committer 2018-10-20 05:42:27 UTC
A commit references this bug:

Author: antoine
Date: Sat Oct 20 05:41:38 UTC 2018
New revision: 482467
URL: https://svnweb.freebsd.org/changeset/ports/482467

Log:
  MFH: r482051

  Fix configure with openssl 1.1.1

  PR:		231970

Changes:
_U  branches/2018Q4/
  branches/2018Q4/irc/irssi/Makefile
  branches/2018Q4/irc/irssi/files/patch-configure.ac