Bug 231973 - devel/boost-all: boost serialization > 1.63 has memory leak
Summary: devel/boost-all: boost serialization > 1.63 has memory leak
Status: Closed Not Enough Information
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-05 10:11 UTC by bye
Modified: 2019-04-18 01:23 UTC (History)
1 user (show)

See Also:


Attachments
Code to reproduce bug (13.50 KB, application/gzip)
2018-10-24 11:46 UTC, bye
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bye 2018-10-05 10:11:23 UTC
There's a memory leak in the boost serialization code that's been there since 1.64

It's still affecting FreeBSD ports.

Here's some background on the bug: https://github.com/boostorg/serialization/pull/69

Here's a fix: https://github.com/boostorg/serialization/pull/79

Can we have the boost maintainers apply this patch in the svn tree?
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2018-10-06 21:03:29 UTC
Take a guess about portname and assign on that basis.
Comment 2 bye 2018-10-24 11:46:20 UTC
Created attachment 198539 [details]
Code to reproduce bug

This is some code that will reproduce the boost bugs.
Comment 3 Kurt Jaeger freebsd_committer 2018-12-22 20:43:57 UTC
devel/boost is now @1.69 and according to 

https://github.com/boostorg/serialization/pull/79

it should fix this issue ? I'm in now way firm in cmake, so I tried this:

tar xf code.tar
cd configure/TestBoostBug
# adding INCLUDE_DIRECTORIES(/usr/local/include) to CMakeLists.txt
cmake CMakeLists.txt
make

It fails with:

[ 75%] Linking CXX executable test_boost
/usr/bin/ld: error: undefined symbol: boost::serialization::extended_type_info::operator==(boost::serialization::extended_type_info const&) const
>>> referenced by test_dll_exported.cpp
>>>               CMakeFiles/test_boost.dir/test_dll_exported.cpp.o:(load_exported(char const*))
Comment 4 Jan Beich freebsd_committer 2019-04-18 01:23:58 UTC
Reopen if this is still an issue and provide a working test case.