Bug 232026 - science/libsvm: Update to 3.23, Take MAINTAINER'ship
Summary: science/libsvm: Update to 3.23, Take MAINTAINER'ship
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Wen Heping
URL: https://www.csie.ntu.edu.tw/~cjlin/li...
Keywords: easy, needs-qa
Depends on:
Blocks:
 
Reported: 2018-10-07 09:14 UTC by Iblis Lin
Modified: 2018-10-13 14:28 UTC (History)
2 users (show)

See Also:
iblis: maintainer-feedback+


Attachments
libsvm 3.23 patch (1006 bytes, patch)
2018-10-07 09:14 UTC, Iblis Lin
koobs: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Iblis Lin 2018-10-07 09:14:34 UTC
Created attachment 197866 [details]
libsvm 3.23 patch

changelog is here: https://www.csie.ntu.edu.tw/~cjlin/libsvm/log
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2018-10-07 12:36:08 UTC
Thank you Iblis, can you confirm that QA (portlint, poudriere) passes please.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2018-10-07 12:36:35 UTC
Comment on attachment 197866 [details]
libsvm 3.23 patch

Approved by: portmgr (unmaintained port)
Comment 3 commit-hook freebsd_committer 2018-10-08 02:06:57 UTC
A commit references this bug:

Author: wen
Date: Mon Oct  8 02:06:54 UTC 2018
New revision: 481502
URL: https://svnweb.freebsd.org/changeset/ports/481502

Log:
  - Update to 3.23
  - Pass maintainership to submitter

  PR:		232026
  Submitted by:	iblis@hs.ntnu.edu.tw
  Approved by:	portmgr@(koobs@)

Changes:
  head/science/libsvm/Makefile
  head/science/libsvm/distinfo
Comment 4 Iblis Lin 2018-10-08 13:29:54 UTC
well, although it has been committed, I provide some QA info.


└─[iblis@abeing]% portlint
WARN: /data/usr/home/iblis/ports/science/libsvm/pkg-descr: exceeds 24 lines, make it shorter if possible.(currently 27 lines)                                                
0 fatal errors and 1 warning found.


poudriere testport with DEFAULT_OPTIONS

 - passed on 11.2-RELEASE, amd64
 - passed on 11.2-RELEASE, i386
 - passed on 10.4-RELEASE, amd64
 - passed on 10.4-RELEASE, i386
Comment 5 Wen Heping freebsd_committer 2018-10-08 14:55:56 UTC
(In reply to Iblis Lin from comment #4)
Thank you !

Would you modify the pkg-descr to pet portlint ?

wen
Comment 6 Iblis Lin 2018-10-08 15:15:14 UTC
(In reply to Wen Heping from comment #5)
sure

---------------

diff --git a/science/libsvm/pkg-descr b/science/libsvm/pkg-descr
index c720a66..443f6a2 100644
--- a/science/libsvm/pkg-descr
+++ b/science/libsvm/pkg-descr
@@ -2,14 +2,8 @@ LIBSVM is an integrated software for support vector classification, (C-SVC,
 nu-SVC), regression (epsilon-SVR, nu-SVR) and distribution estimation
 (one-class SVM). It supports multi-class classification.
 
-Since version 2.8, it implements an SMO-type algorithm proposed in this paper:
-R.-E. Fan, P.-H. Chen, and C.-J. Lin. Working set selection using second order
-information for training SVM. Journal of Machine Learning Research 6,
-1889-1918, 2005. You can also find a pseudo code there.
-
-Our goal is to help users from other fields to easily use SVM as a tool. LIBSVM
-provides a simple interface where users can easily link it with their own
-programs. Main features of LIBSVM include
+LIBSVM provides a simple interface where users can easily link it with their
+own programs. Main features of LIBSVM include
 
   * Different SVM formulations
   * Efficient multi-class classification
Comment 7 Iblis Lin 2018-10-13 08:36:41 UTC
(In reply to Wen Heping from comment #5)
bump.
Comment 8 commit-hook freebsd_committer 2018-10-13 14:26:57 UTC
A commit references this bug:

Author: wen
Date: Sat Oct 13 14:26:24 UTC 2018
New revision: 481987
URL: https://svnweb.freebsd.org/changeset/ports/481987

Log:
  - Update pkg-descr

  PR:		232026
  Submitted by:	iblis@hs.ntnu.edu.tw(maintainer)

Changes:
  head/science/libsvm/pkg-descr
Comment 9 Wen Heping freebsd_committer 2018-10-13 14:28:22 UTC
(In reply to Iblis Lin from comment #7)
Done.

Thank you !

wen