Bug 232054 - graphics/gegl conflicts with sysutils/coreutils (bin/gcut)
Summary: graphics/gegl conflicts with sysutils/coreutils (bin/gcut)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Koop Mast
URL:
Keywords: easy, patch, regression
Depends on:
Blocks:
 
Reported: 2018-10-07 22:07 UTC by Walter Schwarzenfeld
Modified: 2018-10-08 19:36 UTC (History)
4 users (show)

See Also:
tobik: maintainer-feedback? (gnome)


Attachments
gegl.diff (555 bytes, patch)
2018-10-08 04:30 UTC, Tobias Kortkamp
tobik: maintainer-approval? (gnome)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld freebsd_triage 2018-10-07 22:07:27 UTC
gegl and coreutils conflicts
Installing gegl-0.4.8...
pkg-static: gegl-0.4.8 conflicts with coreutils-8.30 (installs files into the same place).  Problematic file: /usr/local/bin/gcut
*** Error code 70
Comment 1 Tobias Kortkamp freebsd_committer 2018-10-08 04:30:39 UTC
Created attachment 197903 [details]
gegl.diff

ports r481475 regresses on the fix committed in ports r457579.

USES=uniquefiles cannot work anymore now because PKGNAMESUFFIX was
dropped.  I'd suggest to set UNIQUE_SUFFIX to -${GEGL_VER} now or
something similar.  Overriding EXAMPLESDIR is also not necessary
anymore.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2018-10-08 13:07:30 UTC
Assign committer of ports r481475
Comment 3 commit-hook freebsd_committer 2018-10-08 15:37:56 UTC
A commit references this bug:

Author: kwm
Date: Mon Oct  8 15:37:35 UTC 2018
New revision: 481547
URL: https://svnweb.freebsd.org/changeset/ports/481547

Log:
  Fix conflict with coreutils. [1]

  Previous in gegl3 the pkgnamesuffix of that port cause gcut to be installed
  as gcut3. Now after the move there isn't a pkgnamesuffix anymore. Base the
  new suffix on the value off GEGL_VER.

  PR:		232054 [1]
  Submitted by:	tobic@
  Reported by:	w.schwarzenfeld@utanet.at

Changes:
  head/graphics/gegl/Makefile
Comment 4 commit-hook freebsd_committer 2018-10-08 19:36:03 UTC
A commit references this bug:

Author: kwm
Date: Mon Oct  8 19:35:47 UTC 2018
New revision: 481558
URL: https://svnweb.freebsd.org/changeset/ports/481558

Log:
  Add missing bits from the patch.

  PR:		232054
  Submitted by:	tobik@

Changes:
  head/graphics/gegl/Makefile