Bug 232073 - graphics/inkscape 0.92.3_3 crash after start, bunch of (inkscape:87801): Gtk-WARNING **, core dump
Summary: graphics/inkscape 0.92.3_3 crash after start, bunch of (inkscape:87801): Gtk-...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-gnome mailing list
URL:
Keywords: regression
: 232305 (view as bug list)
Depends on: 232305
Blocks:
  Show dependency treegraph
 
Reported: 2018-10-08 14:54 UTC by A Seda
Modified: 2018-11-06 15:42 UTC (History)
12 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)
jbeich: merge-quarterly?


Attachments
patch for the patch of Marcin Cieslak (1.65 KB, patch)
2018-10-15 16:23 UTC, Rainer Hurling
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description A Seda 2018-10-08 14:54:28 UTC
Inkscape installed from packages using quaterly repo.
Using XFCE4 desktop with vesa driver (it happens also with nvidia-driver-390). HAlD and DBUS running.


[user@bsd-roy /usr/home/user]$ inkscape

(process:87801): Gtk-WARNING **: 10:16:54.462: Locale not supported by C library.
	Using the fallback 'C' locale.

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.

(inkscape:87801): Gtk-WARNING **: 10:16:58.265: ChannelsAction: missing action ChannelsAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.265: ThresholdAction: missing action ThresholdAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.265: OffsetAction: missing action OffsetAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.265: PaintbucketUnitsAction: missing action PaintbucketUnitsAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.265: AutoGapAction: missing action AutoGapAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.265: PaintbucketResetAction: missing action PaintbucketResetAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextFontStyleAction: missing action TextFontStyleAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextOuterStyleAction: missing action TextOuterStyleAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextFontSizeAction: missing action TextFontSizeAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextLineHeightAction: missing action TextLineHeightAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextLineHeightUnitsAction: missing action TextLineHeightUnitsAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextLineHeightUnsetAction: missing action TextLineHeightUnsetAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextAlignAction: missing action TextAlignAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextSuperscriptAction: missing action TextSuperscriptAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextSubscriptAction: missing action TextSubscriptAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextLetterSpacingAction: missing action TextLetterSpacingAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextWordSpacingAction: missing action TextWordSpacingAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextDxAction: missing action TextDxAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextDyAction: missing action TextDyAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextRotationAction: missing action TextRotationAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextWritingModeAction: missing action TextWritingModeAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextOrientationAction: missing action TextOrientationAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.310: TextDirectionAction: missing action TextDirectionAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: GradientNewTypeAction: missing action GradientNewTypeAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: GradientNewFillStrokeAction: missing action GradientNewFillStrokeAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: GradientSelectGradientAction: missing action GradientSelectGradientAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: GradientEditLinkAction: missing action GradientEditLinkAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: GradientEditReverseAction: missing action GradientEditReverseAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: GradientSelectRepeatAction: missing action GradientSelectRepeatAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: GradientEditStopsAction: missing action GradientEditStopsAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: GradientEditOffsetAction: missing action GradientEditOffsetAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: GradientEditAddAction: missing action GradientEditAddAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: GradientEditDeleteAction: missing action GradientEditDeleteAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshNewTypeAction: missing action MeshNewTypeAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshNewFillStrokeAction: missing action MeshNewFillStrokeAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshRowAction: missing action MeshRowAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshColumnAction: missing action MeshColumnAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshToggleSidesAction: missing action MeshToggleSidesAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshMakeEllipticalAction: missing action MeshMakeEllipticalAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshPickColorsAction: missing action MeshPickColorsAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshFitInBoundingBoxAction: missing action MeshFitInBoundingBoxAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshShowHandlesAction: missing action MeshShowHandlesAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshEditFillAction: missing action MeshEditFillAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshEditStrokeAction: missing action MeshEditStrokeAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshWarningAction: missing action MeshWarningAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.313: MeshSmoothAction: missing action MeshSmoothAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: DropperOpacityAction: missing action DropperOpacityAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: DropperPickAlphaAction: missing action DropperPickAlphaAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: DropperSetAlphaAction: missing action DropperSetAlphaAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: ConnectorAvoidAction: missing action ConnectorAvoidAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: ConnectorIgnoreAction: missing action ConnectorIgnoreAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: ConnectorOrthogonalAction: missing action ConnectorOrthogonalAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: ConnectorCurvatureAction: missing action ConnectorCurvatureAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: ConnectorSpacingAction: missing action ConnectorSpacingAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: ConnectorGraphAction: missing action ConnectorGraphAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: ConnectorLengthAction: missing action ConnectorLengthAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: ConnectorDirectedAction: missing action ConnectorDirectedAction

(inkscape:87801): Gtk-WARNING **: 10:16:58.314: ConnectorOverlapAction: missing action ConnectorOverlapAction
Abort trap (core dumped)

---------------------
locale
LANG=en_US.UTF8
LC_CTYPE="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_ALL=en_US.UTF-8
--------------------
freebsd-version -rku
11.2-RELEASE-p4
11.2-RELEASE-p4
11.2-RELEASE-p4
---------------------
uname -a
FreeBSD bsd-roy 11.2-RELEASE-p4 FreeBSD 11.2-RELEASE-p4 #0: Thu Sep 27 08:16:24 UTC 2018     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
----------------------
pkg info inkscape
inkscape-0.92.3_3
Name           : inkscape
Version        : 0.92.3_3
Installed on   : Sun Oct  7 21:46:10 2018 AST
Origin         : graphics/inkscape
Architecture   : FreeBSD:11:amd64
Prefix         : /usr/local
Categories     : gnome graphics
Licenses       : GPLv2+, LGPL21, MPL11, GPLv3+
Maintainer     : gnome@FreeBSD.org
WWW            : http://www.inkscape.org
Comment        : Full featured open source SVG editor
Options        :
	CDR            : on
	DBUS           : off
	POPPLER        : on
	VISIO          : on
	WPG            : on
Shared Libs required:
	librevenge-stream-0.0.so.0
	libgtk-x11-2.0.so.0
	libglibmm-2.4.so.1
	libgsl.so.23
	libpopt.so.0
	libxslt.so.1
	libpango-1.0.so.0
	libjpeg.so.8
	liblcms2.so.2
	libgtkmm-2.4.so.1
	libfreetype.so.6
	libcairo.so.2
	libgc.so.1
	libxml2.so.2
	libMagickWand-6.so.5
	libMagickCore-6.so.5
	libMagick++-6.so.8
	libcairomm-1.0.so.1
	libatk-1.0.so.0
	libiconv.so.2
	libgmodule-2.0.so.0
	libgdk_pixbuf-2.0.so.0
	libcdr-0.1.so.1
	libgtkspell.so.0
	libpoppler-glib.so.8
	libX11.so.6
	libgio-2.0.so.0
	librevenge-0.0.so.0
	libpangomm-1.4.so.1
	libgobject-2.0.so.0
	libpangoft2-1.0.so.0
	libvisio-0.1.so.1
	libgslcblas.so.0
	libpotrace.so.0
	libglib-2.0.so.0
	libsigc-2.0.so.0
	libatkmm-1.6.so.1
	libgdk-x11-2.0.so.0
	libpng16.so.16
	libintl.so.8
	libaspell.so.15
	libfontconfig.so.1
	libgthread-2.0.so.0
	libgiomm-2.4.so.1
	libpoppler.so.68
	libgdkmm-2.4.so.1
	libwpg-0.3.so.3
	libpangocairo-1.0.so.0
Shared Libs provided:
	libinkscape_base.so
Annotations    :
	FreeBSD_version: 1102000
	cpe            : cpe:2.3:a:inkscape:inkscape:0.92.3:::::freebsd11:x64:3
	repo_type      : binary
	repository     : FreeBSD
Flat size      : 124MiB
Description    :
Inkscape seeks to become a full featured open source SVG editor.
Derived from the highly popular Sodipodi codebase, Inkscape strives
to build full XML, SVG, and CSS2 compliance.

Features include alpha blending, node editing, svg-to-png export,
and more. Project aims for capabilities similar to Illustrator,
CorelDraw, Visio, etc.
Comment 1 Erich Dollansky 2018-10-09 19:00:39 UTC
I have the same problem since I tried to upgrade my ports.
Comment 2 allaonix 2018-10-10 16:57:42 UTC
Me too.
I was able to use it before this update.
FreeBSD 11.2 amd64
Using MATE desktop on VirtualBox


$ inkscape

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.

(inkscape:1300): Gtk-WARNING **: 01:40:24.798: ChannelsAction: missing action ChannelsAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.799: ThresholdAction: missing action ThresholdAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.799: OffsetAction: missing action OffsetAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.799: PaintbucketUnitsAction: missing action PaintbucketUnitsAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.799: AutoGapAction: missing action AutoGapAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.799: PaintbucketResetAction: missing action PaintbucketResetAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextFontStyleAction: missing action TextFontStyleAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextOuterStyleAction: missing action TextOuterStyleAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextFontSizeAction: missing action TextFontSizeAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextLineHeightAction: missing action TextLineHeightAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextLineHeightUnitsAction: missing action TextLineHeightUnitsAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextLineHeightUnsetAction: missing action TextLineHeightUnsetAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextAlignAction: missing action TextAlignAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextSuperscriptAction: missing action TextSuperscriptAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextSubscriptAction: missing action TextSubscriptAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextLetterSpacingAction: missing action TextLetterSpacingAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextWordSpacingAction: missing action TextWordSpacingAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextDxAction: missing action TextDxAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextDyAction: missing action TextDyAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextRotationAction: missing action TextRotationAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextWritingModeAction: missing action TextWritingModeAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextOrientationAction: missing action TextOrientationAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.819: TextDirectionAction: missing action TextDirectionAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: GradientNewTypeAction: missing action GradientNewTypeAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: GradientNewFillStrokeAction: missing action GradientNewFillStrokeAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: GradientSelectGradientAction: missing action GradientSelectGradientAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: GradientEditLinkAction: missing action GradientEditLinkAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: GradientEditReverseAction: missing action GradientEditReverseAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: GradientSelectRepeatAction: missing action GradientSelectRepeatAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: GradientEditStopsAction: missing action GradientEditStopsAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: GradientEditOffsetAction: missing action GradientEditOffsetAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: GradientEditAddAction: missing action GradientEditAddAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: GradientEditDeleteAction: missing action GradientEditDeleteAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshNewTypeAction: missing action MeshNewTypeAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshNewFillStrokeAction: missing action MeshNewFillStrokeAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshRowAction: missing action MeshRowAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshColumnAction: missing action MeshColumnAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshToggleSidesAction: missing action MeshToggleSidesAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshMakeEllipticalAction: missing action MeshMakeEllipticalAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshPickColorsAction: missing action MeshPickColorsAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshFitInBoundingBoxAction: missing action MeshFitInBoundingBoxAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshShowHandlesAction: missing action MeshShowHandlesAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshEditFillAction: missing action MeshEditFillAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshEditStrokeAction: missing action MeshEditStrokeAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshWarningAction: missing action MeshWarningAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: MeshSmoothAction: missing action MeshSmoothAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: DropperOpacityAction: missing action DropperOpacityAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: DropperPickAlphaAction: missing action DropperPickAlphaAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: DropperSetAlphaAction: missing action DropperSetAlphaAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: ConnectorAvoidAction: missing action ConnectorAvoidAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: ConnectorIgnoreAction: missing action ConnectorIgnoreAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: ConnectorOrthogonalAction: missing action ConnectorOrthogonalAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: ConnectorCurvatureAction: missing action ConnectorCurvatureAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: ConnectorSpacingAction: missing action ConnectorSpacingAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: ConnectorGraphAction: missing action ConnectorGraphAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: ConnectorLengthAction: missing action ConnectorLengthAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: ConnectorDirectedAction: missing action ConnectorDirectedAction

(inkscape:1300): Gtk-WARNING **: 01:40:24.825: ConnectorOverlapAction: missing action ConnectorOverlapAction
アボートトラップ (core dumped)
Comment 3 ui 2018-10-11 12:45:48 UTC
I can confirm the problem since I upgraded my ports.

"Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it

..."
Comment 4 aspera81 2018-10-11 16:53:40 UTC
Confirm the problem

11.2-RELEASE-p4 FreeBSD 11.2-RELEASE-p4 #0: Thu Sep 27 08:16:24 UTC 2018     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64

inkscape-0.92.3_3
Comment 5 Donovan 2018-10-11 19:08:57 UTC
Also confirm.

Any fix or workaround?
Comment 6 w.schwarzenfeld freebsd_triage 2018-10-15 10:56:31 UTC
Marcin Cieslak postet a working patch on pipermail:

https://lists.freebsd.org/pipermail/freebsd-ports/2018-October/114474.html
Comment 7 w.schwarzenfeld freebsd_triage 2018-10-15 10:57:10 UTC
The patch is for devel/glibmm.
Comment 8 Rainer Hurling 2018-10-15 16:23:14 UTC
Created attachment 198183 [details]
patch for the patch of Marcin Cieslak

For the patch, postet by Marcin Cieslak on pipermail[1] and reported by Walter Schwarzenfeld, I created a patch for devel/glibmm via 'make makeplist'.

This patch applied clean and after rebuilding devel/glibmm, graphics/inkscape starts and work normal again (on 12.0-ALPHA9 r339335 amd64).

Many thanks!


[1] https://lists.freebsd.org/pipermail/freebsd-ports/2018-October/114474.html
Comment 9 Donovan 2018-10-15 16:55:16 UTC
Patch works. Thanks.
Comment 10 A Seda 2018-10-16 05:04:20 UTC
HI,

Applied patch to devel/glibmm, recompile, install. Seems to be working.
Thanks all.
Comment 11 allaonix 2018-10-21 14:13:31 UTC
Thank you!! I am also able to use Inkscape.
Comment 12 Maxim Usatov 2018-10-26 23:22:18 UTC
Applied patch, reinstalled glibmm, however, inkspace still crashes for me. 

FreeBSD 11.2-RELEASE-p2 #0: Tue Aug 14 21:45:40 UTC 2018     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC
Comment 13 w.schwarzenfeld freebsd_triage 2018-10-26 23:51:54 UTC
Have you also rebuild inkscape?
Comment 14 Maxim Usatov 2018-10-27 07:32:36 UTC
Yes, I have rebuilt inkscape. Just double-checked: patched and rebuilt glibmm then, again, rebuilt inkscape. Getting the same problem.
Comment 15 Maxim Usatov 2018-10-27 09:14:15 UTC
Just to make sure, what I did was: 
- Copy the attachment patch to /usr/ports/devel/glibmm/files 
- In /usr/ports/devel/glibmm: 
# make patch
# make deinstall (to remove the binary package I've had installed)  
# make install 

- Then switched to /usr/ports/graphics/inkscape:
# make deinstall (to remove the binary package) 
# make install
Comment 16 Jan Beich freebsd_committer 2018-10-29 21:27:06 UTC
Reverting devel/glib20 update from ports r480951 appears to help as well. After bisecting I've found the following commit as the first bad:
https://gitlab.gnome.org/GNOME/glib/commit/8abf3a04e699abd486c4dcaa57977203584acf0e

Tijl, Ting-Wei, can you review if the proposed fix is correct or suggest a better one? See also bug 175930 and https://bugzilla.gnome.org/show_bug.cgi?id=795338
Comment 17 Jan Beich freebsd_committer 2018-10-30 18:33:48 UTC
*** Bug 232305 has been marked as a duplicate of this bug. ***
Comment 18 Tijl Coosemans freebsd_committer 2018-10-31 11:58:04 UTC
(In reply to Jan Beich from comment #16)
Patching glibmm like that isn't correct on FreeBSD because the wchar_t encoding depends on the locale.  It is only ucs4 encoded for utf-8 locales (lib/libc/locale/utf8.c).  Both clang and gcc seem to convert wchar_t string literals like L"¹²³" to ucs4 though so I wouldn't be surprised if libc++ also assumes it's ucs4.  With both Linux and MacOS always using ucs4 this is a fight we can't win so I'm all for making wchar_t always ucs4 and defining __STDC_ISO_10646__ (glibc defines it in /usr/include/stdc-predef.h iirc).

In the mean time, if reverting https://gitlab.gnome.org/GNOME/glib/commit/8abf3a04e699abd486c4dcaa57977203584acf0e fixes the problem you can add a patch for that to devel/glib20.
Comment 19 commit-hook freebsd_committer 2018-11-03 06:11:04 UTC
A commit references this bug:

Author: jbeich
Date: Sat Nov  3 06:10:29 UTC 2018
New revision: 483878
URL: https://svnweb.freebsd.org/changeset/ports/483878

Log:
  devel/glib20: revert to old g_convert() behavior

  PR:		232073
  Reported by:	many (via inkscape)
  Suggested by:	tijl
  Tested by:	glib/tests/convert
  MFH:		2018Q4

Changes:
  head/devel/glib20/Makefile
  head/devel/glib20/files/patch-revert-8abf3a0
Comment 20 Jan Beich freebsd_committer 2018-11-03 06:13:39 UTC
Can someone confirm the fix?
Comment 21 Maxim Usatov 2018-11-03 08:55:32 UTC
Rebuilding glib with patch makes inkscape work again. Thank you very much!
Comment 22 w.schwarzenfeld freebsd_triage 2018-11-03 16:53:51 UTC
Also confirm. Works! Thanks!
Comment 23 commit-hook freebsd_committer 2018-11-06 15:42:43 UTC
A commit references this bug:

Author: jbeich
Date: Tue Nov  6 15:42:39 UTC 2018
New revision: 484301
URL: https://svnweb.freebsd.org/changeset/ports/484301

Log:
  MFH: r483878

  devel/glib20: revert to old g_convert() behavior

  PR:		232073
  Reported by:	many (via inkscape)
  Suggested by:	tijl
  Tested by:	glib/tests/convert
  Approved by:	ports-secteam blanket

Changes:
_U  branches/2018Q4/
  branches/2018Q4/devel/glib20/Makefile
  branches/2018Q4/devel/glib20/files/patch-revert-8abf3a0