Bug 232120 - graphics/libmypaint: requires GNU gettext tools even when option NLS is unset
Summary: graphics/libmypaint: requires GNU gettext tools even when option NLS is unset
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Koop Mast
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-09 14:49 UTC by Trond.Endrestol
Modified: 2018-10-11 17:13 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (kwm)


Attachments
Complete build log from synth (18.35 KB, text/plain)
2018-10-09 14:49 UTC, Trond.Endrestol
no flags Details
patch-gettext-tools (475 bytes, patch)
2018-10-10 12:52 UTC, w.schwarzenfeld
no flags Details | Diff
patch-gettext-tools_v2 (470 bytes, patch)
2018-10-11 08:22 UTC, w.schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Trond.Endrestol 2018-10-09 14:49:39 UTC
Created attachment 197967 [details]
Complete build log from synth

Ports tree is at r481554. NLS is unset for graphics/libmypaint.

Relevant sections of the build log is shown below. Complete build log is attached.

checking whether the linker accepts -fsanitize=undefined... yes
checking whether NLS is requested... no
checking for intltool-update... /usr/local/bin/intltool-update
checking for intltool-merge... /usr/local/bin/intltool-merge
checking for intltool-extract... /usr/local/bin/intltool-extract
checking for xgettext... no
checking for msgmerge... no
checking for msgfmt... no
checking for gmsgfmt... no
configure: error: GNU gettext tools not found; required for intltool
===>  Script "configure" failed unexpectedly.
Please report the problem to kwm@FreeBSD.org [maintainer] and attach the
"/construction/xports/graphics/libmypaint/work/libmypaint-1.3.0/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /xports/graphics/libmypaint

--------------------------------------------------
--  Termination
--------------------------------------------------
Finished: Tuesday, 9 OCT 2018 at 06:44:33 UTC
Duration: 00:01:16
Comment 1 Philipp Engel 2018-10-10 11:14:49 UTC
Same error here with same message.
Comment 2 w.schwarzenfeld freebsd_triage 2018-10-10 12:52:45 UTC
Created attachment 198000 [details]
patch-gettext-tools
Comment 3 ml 2018-10-11 07:23:08 UTC
(In reply to w.schwarzenfeld from comment #2)

Tried your patch (with Poudriere on 11.2/amd64), but I still got the same error.
I just added gettext to USES=: it might be too much, but it allowed me to compile.
Comment 4 w.schwarzenfeld freebsd_triage 2018-10-11 08:22:29 UTC
Created attachment 198031 [details]
patch-gettext-tools_v2

Sorry, I puzzled the commands.
Comment 5 commit-hook freebsd_committer 2018-10-11 17:11:44 UTC
A commit references this bug:

Author: kwm
Date: Thu Oct 11 17:10:44 UTC 2018
New revision: 481840
URL: https://svnweb.freebsd.org/changeset/ports/481840

Log:
  Fix the build for when NLS is deselected.

  Disable both nls and i18n support. NLS only disabled gettext support, but
  intltool still needs gettext to work. Which resulted in the configure script
  failing. Move the intltool requirement to the NLS option as a result.

  PR:		232120
  Reported by:	Trond.Endrestol@ximalas.info

Changes:
  head/graphics/libmypaint/Makefile
Comment 6 Koop Mast freebsd_committer 2018-10-11 17:13:27 UTC
Thanks for reporting!