Bug 232145 - sysutils/fusefs-smbnetfs: Error when writing to share (smb_conn_srv_fstat: errno=22, Invalid argument)
Summary: sysutils/fusefs-smbnetfs: Error when writing to share (smb_conn_srv_fstat: er...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-10 04:03 UTC by Tsvetomir Tsonev
Modified: 2019-02-11 12:14 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (mi)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tsvetomir Tsonev 2018-10-10 04:03:01 UTC
Trying to write a file on a share with 0.6.1_1 results in an error:

  srv(24578)->smb_conn_srv_listen: process query=13, query_len=8
  srv(24578)->smb_conn_srv_fstat: errno=22, Invalid argument
  14224->process_kill_by_smb_conn_fd: closing child connection with pid=24578, fd=7

Trace:
 18395 smbnetfs RET   write 87/0x57
 18395 smbnetfs CALL  select(0x8,0x7fffdfdfb610,0,0x7fffdfdfb690,0x7fffdfdfb750)
 18395 smbnetfs RET   select 1
 18395 smbnetfs CALL  read(0x7,0x7fffdfdfb7c0,0x1000)
 18395 smbnetfs GIO   fd 7 read 92 bytes
       0x0000 5c00 0000 0000 0000 fdff ffff 1600 0000 f747 0000 0000 0000 1000 0000 0000 0000 7372 7628 3138 3432 3329 2d3e 736d 625f 636f 6e6e 5f73 7276 5f66 7374 6174  |\................G..............srv(18423)->smb_conn_srv_fstat|
       0x003e 3a20 6572 726e 6f3d 3232 2c20 496e 7661 6c69 6420 6172 6775 6d65 6e74 0a00                                                                                  |: errno=22, Invalid argument..|

Listing and reading files works fine.
The problem is not present in 0.6.1 / samba46.
Comment 1 Mikhail Teterin freebsd_committer 2018-10-21 22:35:53 UTC
I doubt, this is the port's problem. Would you consider, bringing it up with the actual author?
Comment 2 Mikhail Teterin freebsd_committer 2019-02-11 02:12:56 UTC
The one machine, where I use this port myself, has been upgraded a number of times since this report was filed. I never had a problem described. It is likely, something is not quite right the Samba configuration -- not fusefs-smbnetfs.
Comment 3 Tsvetomir Tsonev 2019-02-11 12:14:17 UTC
Could very be an issue specific to the environment. I don't have direct control over the server so it will remain a mystery.