Bug 232150 - net/liboauth: fails to build with openssl 1.1.1 in base
Summary: net/liboauth: fails to build with openssl 1.1.1 in base
Status: Closed DUPLICATE of bug 225919
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Hiroki Sato
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-10 14:30 UTC by O. Hartmann
Modified: 2018-10-10 18:32 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (hrs)


Attachments
patch-openssl (4.00 KB, patch)
2018-10-10 15:08 UTC, Walter Schwarzenfeld
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2018-10-10 14:30:01 UTC
On recent FreeBSD CURRENT (12.0-ALPHA9 #160 r339274: Wed Oct 10 06:52:16 CEST 2018 amd64) with openssl 1.1.1 in base, port net/liboauth fails to build:

libtool: compile:  cc -DHAVE_CONFIG_H -I. -Wall -I/usr/local/include -O2 -pipe -march=native -fstack-protector -fno-strict-aliasing -MT liboauth_la-oauth.lo -MD -MP -MF .deps/liboauth_la-oauth.Tpo -c oauth.c -o liboauth_la-oauth.o >/dev/null 2>&1
--- liboauth_la-oauth_http.lo ---
mv -f .deps/liboauth_la-oauth_http.Tpo .deps/liboauth_la-oauth_http.Plo
--- liboauth_la-hash.lo ---
hash.c:389:14: error: variable has incomplete type 'EVP_MD_CTX' (aka 'struct evp_md_ctx_st')
  EVP_MD_CTX md_ctx;
             ^
/usr/include/openssl/ossl_typ.h:92:16: note: forward declaration of 'struct evp_md_ctx_st'
typedef struct evp_md_ctx_st EVP_MD_CTX;
               ^
hash.c:419:14: error: variable has incomplete type 'EVP_MD_CTX' (aka 'struct evp_md_ctx_st')
  EVP_MD_CTX md_ctx;
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-10-10 15:07:59 UTC
I am not sure, I got it from here:
https://patchwork.openembedded.org/patch/154574/
but try that patch.
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-10-10 15:08:43 UTC
Created attachment 198003 [details]
patch-openssl
Comment 3 Antoine Brodin freebsd_committer 2018-10-10 18:32:16 UTC
Please move your patch to bug #225919 if you think it's better.

*** This bug has been marked as a duplicate of bug 225919 ***