Bug 232196 - devel/tbb: fails to install pkg-static: Unable to accesss file *_org.svg
Summary: devel/tbb: fails to install pkg-static: Unable to accesss file *_org.svg
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Ganael LAPLANCHE
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-12 02:29 UTC by Christopher
Modified: 2018-10-17 18:15 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (martymac)


Attachments
patch to update pkg-plist (75.12 KB, patch)
2018-10-12 10:51 UTC, Rainer Hurling
no flags Details | Diff
First patch attempt (402 bytes, text/plain)
2018-10-12 11:20 UTC, Ganael LAPLANCHE
no flags Details
Error output (15.42 KB, text/plain)
2018-10-16 12:41 UTC, Rob Belics
no flags Details
Build log (643.34 KB, application/octet-stream)
2018-10-16 15:34 UTC, Rob Belics
no flags Details
log of build and install of devel/tbb (685.64 KB, text/plain)
2018-10-16 15:56 UTC, Rainer Hurling
no flags Details
Second patch attempt (487.45 KB, patch)
2018-10-17 15:37 UTC, Ganael LAPLANCHE
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher 2018-10-12 02:29:16 UTC
This version (tbb-2019.1) is failing installation on multiple computers (both amd64 & i386).  These are all relatively new installs (created in Aug. 2018)

Example of error message:

pkg-static: Unable to accesss file /usr/ports/devel/tbb/work/stage/usr/local/share/doc/tbb/a04703_ae43166ffd9d7fb624158872394832f17_icgraph_org.svg

The list of .svg files that are missing is pretty long, but all seem to belong in the same directory.
Comment 1 Rainer Hurling 2018-10-12 10:51:02 UTC
Created attachment 198058 [details]
patch to update pkg-plist

I ran against the same build failures. For me it helped to create a new pkg-plist via 'make makeplist'. A diff against the old pkg-plist is attached.
Comment 2 Ganael LAPLANCHE freebsd_committer 2018-10-12 11:07:49 UTC
Hi,

Thanks for submitting that bug report.

There seem to be a problem with SVG file generation, maybe related to local Doxygen port options (building devel/tbb in poudriere with *default* port's and dependencies' options does not trigger the problem).

Can you tell me what options are enabled on your side for devel/doxygen ?

If you really need the port before it gets fixed, disable the DOCS option and 
retry, it should do it.
Comment 3 Rainer Hurling 2018-10-12 11:10:43 UTC
(In reply to Ganael LAPLANCHE from comment #2)

Hi, on my box only default options DOCS, GRAPHVIZ and LATEX are enabled.

Thanks for your work.
Comment 4 Ganael LAPLANCHE freebsd_committer 2018-10-12 11:20:44 UTC
Created attachment 198059 [details]
First patch attempt

Add missing dependency
Comment 5 Ganael LAPLANCHE freebsd_committer 2018-10-12 11:21:44 UTC
Doxygen can use the 'dot' binary from graphics/graphviz port to generate advanced diagrams and that dependency has been omitted in the original commit.

Would the attached patch fix SVG files generation ?
Comment 6 Ganael LAPLANCHE freebsd_committer 2018-10-16 10:17:14 UTC
Hi Rainer,

Unfortunately, I cannot reproduce the build problem through poudriere (with default options).

As you are building the port manually, I presume there is a missing dependency somewhere (or, maybe, only the 'dot' binary) that silently prevents the port from building SVG files, but I don't know what it is.

Could you (or someone) try my patch + send me the full build logs ?
Comment 7 Rob Belics 2018-10-16 12:41:16 UTC
Created attachment 198205 [details]
Error output

My error output building from ports.
Comment 8 Ganael LAPLANCHE freebsd_committer 2018-10-16 15:29:20 UTC
Thanks,

Can you upload the full build logs (not just the registering part) ?
Comment 9 Rob Belics 2018-10-16 15:34:56 UTC
Created attachment 198219 [details]
Build log
Comment 10 Rainer Hurling 2018-10-16 15:56:36 UTC
Created attachment 198224 [details]
log of build and install of devel/tbb

Hi Ganael,

thanks for your patch. Yes, I test built outside of Poudriere, on a real world box. This is a scenario for building ports from sources, with portmaster.

Unfortunalely, the install also fails with your patch, with original pkg-plist. The attached 'tbb.log' is created with 'MAKE_JOBS_UNSAFE=yes'.
Comment 11 Ganael LAPLANCHE freebsd_committer 2018-10-17 15:37:43 UTC
Created attachment 198273 [details]
Second patch attempt
Comment 12 Ganael LAPLANCHE freebsd_committer 2018-10-17 15:39:42 UTC
Hi,

Thanks for your feedback/logs.

Good news: I could finally reproduce the problem with a manual build.

What I have found :

- With poudriere, the problem does *not* occur. It occurs with a manual build.
- It occurs with the *exact* same configuration/options (for all dependencies) between poudriere and the manual (failing) build
- Build logs are exactly the same between poudriere and the manual build (i.e. no visible error)

Also, it seems that the files missing on my failing build host are only a subset of the ones I received through that PR. I don't know why I don't get the exact same list of missing files.

Those files are _org.svg suffixed which are related to Doxygen interactive SVG option. As a workaround, I have disabled interactive SVG generation, which prevents all *_org.svg files from being generated. Can you try that second patch patch ?
Comment 13 Rainer Hurling 2018-10-17 16:05:28 UTC
(In reply to Ganael LAPLANCHE from comment #12)

Hi Ganael,

Thanks for the second patch. It patches, builts and installs fine on my box (outside of Poudriere).
Comment 14 commit-hook freebsd_committer 2018-10-17 17:50:37 UTC
A commit references this bug:

Author: martymac
Date: Wed Oct 17 17:50:04 UTC 2018
New revision: 482301
URL: https://svnweb.freebsd.org/changeset/ports/482301

Log:
  Add missing dependency and fix plist troubles when DOCS is on

  PR:		232196
  Submitted by:	Christopher <inbox@alleghenycomputer.com>

Changes:
  head/devel/tbb/Makefile
  head/devel/tbb/files/patch-Doxyfile.txt
  head/devel/tbb/pkg-plist
Comment 15 Ganael LAPLANCHE freebsd_committer 2018-10-17 17:55:47 UTC
Hi Rainer,

Thanks for your feedback, I've just committed the patch!

(and thanks, everyone, for your help!)

Best regards,

Ganael.
Comment 16 Rainer Hurling 2018-10-17 18:15:18 UTC
(In reply to Ganael LAPLANCHE from comment #15)

You are welcome. Any many thanks again for your patches and patience.