Bug 232280 - graphics/gimp-app: Failed to upgrade from 2.8.22_1,1 to 2.10.6_1,1
Summary: graphics/gimp-app: Failed to upgrade from 2.8.22_1,1 to 2.10.6_1,1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Baptiste Daroussin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-15 12:24 UTC by Raphael Kubo da Costa
Modified: 2019-09-29 09:37 UTC (History)
3 users (show)

See Also:
kwm: maintainer-feedback-


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Kubo da Costa freebsd_committer 2018-10-15 12:24:42 UTC
I've tried both pkg-devel 1.10.99.10 as well as pkg-static 1.10.99.8 on -CURRENT, and "pkg upgrade gimp-app" always fails:

pkg: Fail to create temporary file: /usr/local/libexec/gimp/2.2/plug-ins/align-layers/.align-layers.Zs6cBw0xzHff:Not a directory
Comment 1 Raphael Kubo da Costa freebsd_committer 2018-10-15 16:04:51 UTC
+bapt

Uninstalling gimp-app and installing the new package works fine.
Comment 2 Koop Mast freebsd_committer 2018-10-15 19:34:27 UTC
Over to pkg@.

The problem here is that gimp installed the plugins previous in:
libexec/gimp/2.2/plug-ins/${pluginname}

But in 2.10 they changed it to:
libexec/gimp/2.2/plug-ins/${pluginname}/${pluginname}

It seems pkg can't grok this it was previous a file and now a directory change.
Comment 3 Baptiste Daroussin freebsd_committer 2019-04-19 14:17:29 UTC
(In reply to Koop Mast from comment #2)
this one is an interesting but that won't be easy to deal with.

I am keeping that to work on it after the next major release of pkg
Comment 4 kunda 2019-07-19 01:17:19 UTC
gimp port has been updated to 2.10.12 
Can this issue still be reproduced ?
Comment 5 Raphael Kubo da Costa freebsd_committer 2019-09-29 09:37:24 UTC
I haven't had issues with subsequent versions, and since then there have been a few major pkg releases, so I'm tentatively marking this one as fixed.